Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I configure a new remote desktop connection to connect to servers I often forget to uncheck the option inside of local devices and resources for remote printers. This creates exceptions in the event log for the server I connect of source: TerminalServices-Printers for the printer drivers I use for PDF document conversion.

I'd love to know if it's possible to disable remote printers by default either on the client remote desktop connection options, or on the server so these exceptions no longer occur.

share|improve this question

4 Answers 4

up vote 11 down vote accepted

RDP printer sharing is on by default in remote desktop, unfortunately:

The printer redirection feature is enabled by default in Windows XP Professional when you enable Remote Desktop. To disable it, use Terminal Services Group Policies. Use Remote Desktop Connection to disable printer redirection on an individual computer. On the Local Resources tab, clear the Printers check box.

So, you have to edit the Terminal Services Group Policy .. but this requires that the Group Policy Management Console be installed. Apparently it is an add-in for Windows Server 2003, but an off-by-default part of the install for Windows Server 2008.

Apparently you can also use the local Group Policy Editor like so:

  1. Click Start, and then click Run.
  2. In the Open box, type mmc, and then click OK.
  3. On the File menu, click Add/Remove Snap-in.
  4. Click Add.
  5. Under Available Stand-alone Snap-ins, click Group Policy, and then click Add.

The relevant section to edit is documented here.

Computer Configuration\Policies\Administrative Templates\
Windows Components\Terminal Services\
Terminal Server\Printer Redirection
share|improve this answer
    
Great post. Thank you! Windows Server 2008 is so much better for GPO's than 2003 where you had to add custom files to accomplish GPO for limiting access to removable media. –  user79052 Apr 21 '11 at 1:52

Within your group policy object, go to Computer Configuration - Windows Components - Terminal Services - Client/Server data redirection - "Do not allow client printer redirection". Set it to Enabled.

If you don't see the section in your group policy object, you may have to manually add the system.adm template to the policy first.

*Edit: I should also probably add that this group policy should be applied to the server, not on the client. And you can do it using the local group policy object if the server isn't actually in a domain.

share|improve this answer
    
Thought about this before never did anything about it, thanks for the tip. –  Richard Slater May 7 '09 at 7:39

For Windows 2008 R2 this is under Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Printer Redirection on the managment console snap in.

share|improve this answer

For whom may won't touch the GP at windows 2003 server run --> tscc.msc

at the connection --> RDP (Properties) in client setting tab

You can change the way client map it resources to the terminal session

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.