Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have defined storage pool for VMs on ZFS:

virsh # pool-dumpxml zfs
<pool type='dir'>
  <capacity unit='bytes'>210316853248</capacity>
  <allocation unit='bytes'>32768</allocation>
  <available unit='bytes'>210316820480</available>

Created RAW image file for vms:

host /winvm/win1 % l
total 3.5K
drwxrwxr-x. 2 root         root           3 Jan  3 14:03 .
drwxr-xr-x  3 libvirt-qemu libvirt-qemu   3 Dec 30 13:45 ..
-rw-------. 1 libvirt-qemu libvirt-qemu 20G Jan  3 14:03 t1.raw

Defined t1 VM but when I try to start it:

host /winvm/win1 % virsh start t1
error: Failed to start domain t1
error: internal error process exited while connecting to monitor: char device redirected to /dev/pts/13
kvm: -drive file=/winvm/win1/t1.raw,if=none,id=drive-sata0-0-0,format=raw,cache=none: could not open disk image /winvm/win1/t1.raw: Invalid argument

The VM's storage file keeps changing owner to root:root:

host /winvm/win1 % ls -l
total 1
-rw-------. 1 root root 21474836480 Jan  3 14:03 t1.raw

I have SELinux disabled on that machine:

host /winvm/win1 % sestatus
SELinux status:                 disabled

Even changed user and context for it:

host /winvm/win1 % chcon -t virt_image_t -u libvirt-qemu t1.raw

And I still keep getting the error above. Why? And how can SELinux impact file access when it's disabled?

share|improve this question
the pool is actived? – c4f4t0r Jan 4 '14 at 8:26
up vote 1 down vote accepted

It's not ZFS, it's virt-manager utility that is causing incorrect configuration - the culprit is if=none added for some reason to disk spec (I've used virt-manager to define raw disk on ZFS volume). I was getting intermittent 'permission denied' errors on the disk image and so I thought it was a question of permissions. That's what happens if you set all the available options on disk image in virt-manager, apparently everyone just leaves the defaults on.

share|improve this answer
Thanks for the hint, one need to set : cache-mode=Hypervisor Default – Arman May 12 at 10:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.