Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've tried working around this with pfctl (seeing as ipfw is deprecated) but I can't seem to get it to work. Using this page as a guide, I've tried multiple variations in /etc/pf.conf, including something as broad as:

pass in proto { tcp, udp } from any to any port 9001

I'm not familiar with pfctl so it's a distinct possibility I'm messing something up.

Details: - Host: OS X 10.8.5

  • VM: Ubuntu 12.04 Server

  • VM Adapters: (1) NAT, (2) Host-only adapter with DHCP disabled - interface of "vboxnet0"

  • XDebug configured to work on port 9001

I believe that the OS X firewall is the problem because if I turn it off (or add netbeans as an application exception) xdebug/netbeans start working together.

share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.