Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I don't know exactly I can do this or not, this is my scenario :

There are two computers on a same network, one with windows8 and me ( CentOS ) .

The one with windows8 is using proxy to connect to internet, and I dont have any software to do that . and I have to use proxy , because of internet filtering in my country .

So, I want to use that system to connect to internet by proxy .

I set my proxy IP and port to 192.168.1.101:9666 ( user's local IP ),and the proxy server's port ( like in his browser's setting ).

I tried that and Im getting this error : The proxy server is refusing connections

is it right? Can I do this like that? What I missed ?

by the way, my browser is firefox .

share|improve this question

closed as off-topic by cstamas, RobM, Falcon Momot, Jenny D, mdpc Jan 6 at 3:34

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is dedicated to professional system and network administrators. End user and enthusiast questions are off-topic (contact your system administrator or hire a professional to help you out). Please see the Help Center for more information." – RobM, Jenny D, mdpc
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Are you even running proxy server software on the machine with the IP address 192.168.1.101? Just because that machine is using a proxy server doesn't mean a second computer can access it as a proxy server. –  Bert Jan 4 at 19:04
    
the Ultrasurf software is running on that machine –  Alireza Fallah Jan 4 at 19:25

1 Answer 1

You can configure 1 machine running TOR proxy as a gateway for other devices on your network. This is useful if you can change the proxy settings on device but you cannot install the TOR software itself.

Edit your torrc in %appdata%\tor\ Change the SocksListenAddress to the machines IP address.

SocksListenAddress 192.168.1.101

Next allow connections from your local network. Restart TOR after making these changes.

SocksPolicy accept 192.168.1.0/24

share|improve this answer
    
can you give more details ? how exactly I should do that? –  Alireza Fallah Jan 4 at 19:24
    
Did you locate your torrc file? Info on the project's website. –  Bert Jan 4 at 19:27
    
the machine is not running tor, its running ultrasurf –  Alireza Fallah Jan 4 at 19:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.