Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have just upgraded my Ubuntu 12 server to php 5.5.7 which in turn automatically upgraded my installation of Apache to 2.4.6. After the upgrade my previous installation of SVN running with WebDAV has now stopped working.

When I try installing subversion and libapache2-svn I get the following:

root@Svr01:/# apt-get install subversion libapache2-svn
Reading package lists... Done
Building dependency tree
Reading state information... Done
subversion is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libapache2-svn : Depends: apache2.2-common but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

"The following packages have unmet dependencies: libapache2-svn : Depends: apache2.2-common but it is not going to be installed"

I am assuming this means that SVN simply does not work with Apache 2.4.6 yet?

Does anyone know a way around this?

share|improve this question

1 Answer 1

Apache modules need to be built at least for the minor version of Apache they are running under. You're using a binary module that was built for 2.2.x. You'll need to use 2.2.x, build your own copy of Subversion or find another binary package that is built against 2.4.x.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.