Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When i access https://xxx.xxx.xxx.xxx:5432/, i can get reseponse from the server. (https with 5432, for test purpose). But when i do tcpdump on server ‘xxx.xxx.xxx.xxx’, it doesn’t show me anything but empty.

belows are what i typed and the result.

# tcpdump port 5432
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on usb0, link-type EN10MB (Ethernet), capture size 96 bytes

I could get tcpdump result from other http service on the server xxx.xxx.xxx.xxx. I tried tcpdump without any query string, so i could see all traffis, but there were nothing relevant to 5432 port. Is this feature of https or ssl? But even though https use encryption, no result at all is incomprehensible. There should be anything that notice me that something is going on. I also tried other packet sniffing program, wireshark, but i got nothing, even encrypted packet. I’m very embarrased with this. What is going on here and how can i get any packet? I don’t need decrypted packet, just want to see “something is working on here” from tcpdump.

Thanks in advance for any help

share|improve this question
    
Looking at the right (-i) interface? –  andol Jan 7 at 5:03

1 Answer 1

up vote 1 down vote accepted

Do you really mean to be listening on interface usb0 with tcpdump? Typically you would be monitoring an Ethernet interface. Like @andol says in their comment, you probably want to be using the -i command-line argument and specifying an Ethernet interface (eth0, etc).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.