Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Just got a new CentOS 5.3 server, trying to get the GUI started. Figured out the command is startkde (I think it is anyway). The KDE loads, and I see my desktop, but when I open folders they don't show up on the desktop, when I click buttons they don't pop up, etc. However, if I open folders, and on my Mac 'split view' all the open apps, I see the opened folder I picked as one, but when I click on it it just brings KDE back. Am I doing this wrong? Anyone know how to properly get KDE working on a general CentOS 5.3 installation?

edit: Here is a more complete story.

Just got the new CentOS 5.3 server today, as I mentioned. I'm trying to SSH into it from my mac on the same network. SSH is fine, but I want to try out the GUI. I've tried ssh, ssh -X, ssh -Y, ssh -XY, and none of those have allowed startx (just throws errors), or startkde (KDE desktop/gui loads in an x window, but everytime i open a folder or click on the start bar, nothing happens on the kde desktop. HOWEVER, if I scatter my mac applications using f3, i can see separate x windows BEHIND the kde desktop that are the opened folders i click on or the kde start bar. so everything i'm trying to open in kde is opening behind my kde desktop x window.) to function properly. And now I'm stumped as to how to get this thing to let me use the GUI.

edit 2: this also happens with gnome when i try to open folders; they open behind the gnome desktop in a separate x window.

share|improve this question
    
Can you clarify the Mac part? Are you logging into this server remotely? –  Mr. Shiny and New 安宇 Aug 20 '09 at 12:39

2 Answers 2

up vote 1 down vote accepted

Run a VNC or NX server - this is the better (only correct?) way to remotely access a full desktop environment remotely. An SSH session with X forwarding will generally push individual windows back to you, ie where you run a single application and just want to see that app window.

I can't remember off the top of my head the default vnc server for CentOS 5.3 - yum list "vnc" should help you find it though.

share|improve this answer

My guess is you have not installed kde properly. Try running

yum groupinstall "KDE (K Desktop Environment)"
share|improve this answer
    
@abbot: the server came with centos (and kde by extension) installed :(. although i guess that doesn't rule out the possibility of them doing it wrong –  hatorade Aug 20 '09 at 12:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.