Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

maybe somone can point me in the right direction with this. A Domain (kat.mydomain.de) pointed to a Ubuntu Server. We set up a new server and changed the Ip adress of the url to the new Server Ip. This seems to work (if I check this with trace).

On the new Ubuntu 12.04 runs a Apache/2.2.22. Apache should now redirect the url to the Folder /var/www/kat as the old server did. (The root Folder is /var/www)

Under /etc/apache2/sites-available reside default and default-ssl

default looks like this (only the important looking part)

   <Directory />   
       Options None
       AllowOverride All
       Deny from all
    </Directory>

    DocumentRoot /var/www/
        <Directory />
            Options FollowSymLinks
            AllowOverride All
        </Directory>

        <Directory /var/www/>
            Options FollowSymLinks MultiViews
            AllowOverride All
            Order allow,deny
            allow from all
        </Directory>

       <Directory /var/www/kat>
            Options FollowSymLinks MultiViews
            AllowOverride All
            Order allow,deny
            allow from all
       </Directory>

    <VirtualHost *>
         ServerAdmin webmaster@localhost
         Alias /doc/ "/usr/share/doc/"
        <Directory "/usr/share/doc/">
            Options Indexes MultiViews FollowSymLinks
            AllowOverride All
            Order deny,allow
            Deny from all
            Allow from 127.0.0.0/255.0.0.0 ::1/128
        </Directory>

    </VirtualHost>

    <VirtualHost *>
        ServerName kat.mydomain.de
        DocumentRoot /var/www/kat
    </VirtualHost>

Under /etc/apache2/sites-enable reside 000-default and 000-default_bak

which I can post when needed. But will not by now because of there length.

$ apache2ctl -S

gives me:

VirtualHost configuration:
wildcard NameVirtualHosts and _default_ servers:
*:*      ds80-234-188-100.dedicated.hosteurope.de (/etc/apache2/sites-enabled/000-default:65)
*:*      kat.mydomain.de (/etc/apache2/sites-enabled/000-default:89)
*:80     is a NameVirtualHost
         default server ds80-234-188-100.dedicated.hosteurope.de (/etc/apache2/sites-enabled/000-default_bak:1)
         port 80 namevhost ds80-234-188-100.dedicated.hosteurope.de (/etc/apache2/sites-enabled/000-default_bak:1)
Syntax OK

Of course I tried to setup a new conf file in sites-available for the vhost and enabled it with en2site. Which didn´t work either. All calls to kat.mydomain.de end in the root dir /var/www.

Thankful for every help,

tony

share|improve this question
    
oh now seems NameVirtualHost * was missing! –  t Book Jan 8 at 16:32
    
you mean you solved it? –  ETL Jan 8 at 19:05
add comment

1 Answer

I needed to add NameVirtualHost * to get this working

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.