Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Why interrupts are confined to CPU0, rather than using other cores that are available? Only for LOC: I could see the interrupts being distributed to other cores why it's not happening for eth0 and eth1?

           CPU0       CPU1       CPU2       CPU3
  0: 3860081907          0          0          0    IO-APIC-edge  timer
  1:         20          0          0          0    IO-APIC-edge  i8042
  6:          5          0          0          0    IO-APIC-edge  floppy
  7:          0          0          0          0    IO-APIC-edge  parport0
  8:          0          0          0          0    IO-APIC-edge  rtc
  9:          0          0          0          0   IO-APIC-level  acpi
 12:        240          0          0          0    IO-APIC-edge  i8042
 14:   11651412          0          0          0    IO-APIC-edge  ide0
 51:   63756555          0          0          0   IO-APIC-level  ioc0
 59:          1          0          0          0   IO-APIC-level  vmci
 67:   20176527          0          0          0   IO-APIC-level  eth0
 75:   98414043          0          0          0   IO-APIC-level  eth1
NMI:          0          0          0          0
LOC: 3887753782 3887746069 3887748988 3887748054
ERR:          0
MIS:          0

I checked smp_affinity file for eth0, but I couldn't make out much from it.

cat /proc/irq/67/smp_affinity
00000000,00000000,00000000,00000000,00000000,00000000,00000000,00000001
share|improve this question
    
I'm not sure what you're asking. Are you experiencing performance issues? –  Katherine Villyard Jan 9 at 3:43
    
@KatherineVillyard No i was a bit curious why all my other CPU cores have 0 count other than CPU0. Is there any specific reason? –  user204857 Jan 9 at 3:46
    
Is the irqbalance daemon running? –  ewwhite Jan 9 at 5:52
    
@ewwhite Thanks for pointing that out. i was not aware of irqbalance, did a bit googling on it. Once again thanks –  user204857 Jan 9 at 8:34

1 Answer 1

up vote 2 down vote accepted

You may want to enable irqbalance if it is not currently running on the system.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.