Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am working on a Final Cut Server setup with an associate and one of the things we need to do is setup XSan2 with two Apple XServe RAID units.

I am able to get into the RAID Administrator and configure arrays etc, however regardless of the configuration I set I am unable to have the LUNs presented to XSan in order to tag them for a storage pool.

I have tried:

  • Blank configuration (No Arrays)
  • RAID5 array
  • JBOD configuration (this I would expect to work, however.. no)

Unfortunately I can't seem to find the information I need in the XSan or XServe RAID documentation, and the same goes for web searches and looking through the training books from Peach Pit.

To elaborate on our setup:

  • We have 4x Apple XServe servers, two with Fiber cards which will the the XSan Metadata controllers (1x master, 1x backup)
  • We have two Apple XServe RAID units with a total capacity (approx.) of 2.75Tb for each controller.
  • We have a fiber switch interconnecting the 2x Metadata Controllers, the 4x RAID controllers, plus, when we've installed the system, 2x Mac Pro edit suites for Edit-in place.
  • There is also a Gigabit switch for connecting the servers and the RAID controllers for management.

Essentially we will have the two remaining XServes running as QMaster nodes interfacing with Finalcut server. The Edit Suites will be direcly attached to the SAN via Fiber on the same fabric as the servers. QMatic nodes and regular workstations will access the data over AFP shares, though if the QMatic machines are experiencing bottlenecks with disk access we can upgrade them to be attached via the Fabric.

In regards to the LUN tagging for the storage pools we have the following planned:

  • HD Video configuration (Metadata/Journal, Video, Audio and Other tags)
  • 1x 80gb Mirror for Metadata/Journal
  • 2x 2.75Tb RAID5 arrays for Video
  • 1x 2.75Tb RAID5 array for Audio
  • 1x 1.xxTB RAID5 array for Other

Anyone know how to make this stuff hum?

share|improve this question
Please further describe your existing Xsan setup that you're looking to add storage to, esp. metadata controllers, metadata network switches, fibre switches, RAIDs, RAID sets, storage pools, etc. Or is this your initial configuration? – morgant Aug 20 '09 at 14:37

Maybe this will help?

share|improve this answer
up vote 1 down vote accepted

Here's what I did to resolve the issue - it was, more or less, a requirement for patients...

We blew the RAID configurations away and re-allocated the RAIDs as detailed above. When attempting to create the volume we were then able to allocate the LUNs to the tags (note: don't name your meta data LUN 'metadata' - the system doesn't seem to like that) and go ahead and create the volume.

However, when the system tried to mount the volume it came up with a very non descriptive error. Looking at the console for the logs we saw that there was an error saying 'fsmpm not started' (which was slightly cryptic).

Anyways long story short, we needed to add an additional IP address to our NICs for the metadata network (10.0.10.x) and then everything played nicely.

This may or may not be the right solution - I'm still not 100% convinced that the network configuration is correct (this is the first OSX stack I've worked on setting up, so its a learning effort) - so if I find I've made mistakes I'll be sure to update this.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.