Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

After upgrading my router, I am unable to mount NFS shares from a Debian server on an OS X client. I have updated /etc/exports according to the new IP address of the client (first line previously worked with the old IP, second is a MWE):

/mnt/backup  192.168.3.3/255.255.255.0(ro,sync,no_subtree_check,insecure)
/mnt/backup  *(rw,no_subtree_check)

I've applied the changes with

exportfs -ar

And have also restarted the daemons:

/etc/init.d/nfs-kernel-server restart
/etc/init.d/nfs-common restart

All with no errors. showmount -e on the server returns an empty list and I am unable to mount the share from the OS X client. rpcinfo -p shows versions 2-4 of NFS, and nfsstat –s has an entry for "Server nfs v3". Any ideas?

share|improve this question
    
iptables? can you mount the volume on the localhost? –  ethrbunny Jan 10 at 17:27
    
You shouldn't be specifying the same mount point on multiple lines. If you need to define multiple clients with different options you should use a space separated list. –  yoonix Jan 10 at 18:52
    
After leaving the machine overnight, showmount now lists the partition, and it is mountable. Strange... but at least now it's working... Thanks for the tip about mountpoints defined on multiple lines @yoonix –  lyineyes Jan 11 at 7:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.