Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

On my asterisk server, when i do a sip reload, i get the message "Using SIP CoS mark 4", followed by a registration time out.

I need to make that statement say "Using SIP CoS mark 5". How do I change the SIP CoS mark 4 to SIP CoS mark 5?

share|improve this question

2 Answers 2

In sip.conf, there are four parameters that control the TOS settings: tos_sip, tos_audio, tos_video and tos_text. tos_sip controls what TOS SIP call signaling packets are set to. tos_audio, tos_video and tos_text control what TOS values are used for RTP audio, video, and text packets, respectively.

There are four parameters to control 802.1p CoS: cos_sip, cos_audio, cos_video and cos_text. The behavior of these parameters is the same as for the SIP TOS settings described above.

By default, the CoS is already set to 5 for audio traffic. Signalling is set to 3. In all honesty, those values are pretty standard. Its unusual to change them in the majority of environments. I'm really not sure why you would see CoS mark 4. There is nothing using that by default.

You can read more info here: https://wiki.asterisk.org/wiki/display/AST/IP+Quality+of+Service

share|improve this answer

I have no idea why, but I had to reboot my server. Now things are magically working again, and asterisk is back in CoS mark 5. Now instead of doing sip reload in CLI, I do a /etc/init.d/asterisk restart from bash.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.