Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

In the "Additional Connection Parameters" tab of the login form for SQL Server Management Studio (most recent versions), one may specify custom connection string parameters. See http://technet.microsoft.com/en-us/library/cc645898.aspx.

I need to add the same custom connection string parameter each time I connect to a database, and that may be many times per day. It takes a few seconds to type this connection string parameter, and I'd like to know how to get that "Additional Connection Parameters" dialog box to always be populated with something I specify. I imagine there would be a registry key or LocalData file where this needs to be hacked in, if it were possible at all.

For example, how do I get the following to always be added to the additional connection parameters?

;multisubnetfailover=true; 

In this example, I am telling the SSMS to attempt connections to all IPs published in DNS for the hostname specified on the Login dialog. This is because my team is using AAGs in SQL Server 2012 just about everywhere.

UPDATE: I checked the registry settings for anything resembling SSMS keys, as well as the .vssettings file for SSMS (its built with Visual Studio SDK, after all), but still don't see anywhere to sneak in such a persisted setting. And, here is a pretty recent MS Connect Feedback Suggestion. If you found this ServerFault question, you will want to go ahead and up-vote that suggestion.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

currently this appears to be a bug in SSMS (present v 2014). I develop SSMSBoost add-in for SSMS and starting from recent release we have fixed that problem. You can use our "Preferred connections" and specify "Additional connection parameters", which will be saved by our add-in correctly. Hope this helps !

share|improve this answer
1  
Thanks, not a big fan of add-ins, but at least you have provided a viable workaround. –  Greg Sep 16 at 16:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.