Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Django Gunicorn server running on an Ubuntu VPS at 0.0.0.0:8000, and while there are some problems with it, it appears to be accepting localhost connections. I have the following in my sites-enabled configuration file:

<VirtualHost *:80>
    ServerName pragmatometer.com
    ServerAlias www.pragmatometer.com analyticalnoticeboard.com www.analyticalnoticeboard.com logisticmvc.com www.logisticmvc.com
    ServerAdmin CJSHayward@PObox.com

    DocumentRoot /home/jonathan/classicorthodoxbible.com
    <Directory />
        Options FollowSymLinks
        AllowOverride None
    </Directory>
    <Directory /var/www/>
        Options ExecCGI Indexes FollowSymLinks MultiViews
        AllowOverride None
        Order allow,deny
        allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
        AllowOverride None
        Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
        Order allow,deny
        Allow from all
    </Directory>

    ErrorLog ${APACHE_LOG_DIR}/author.cjshayward.error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    CustomLog ${APACHE_LOG_DIR}/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

    ProxyPass / http://localhost:8000/
    ProxyPassReverse / http://localhost:8000/

</VirtualHost>

When I try to connect to http://logisticmvc.com/, I get an Apache (not Gunicorn) 500 error page, but nothing new is logged in /var/log/apache2/error.log.

Are the ProxyPass and ProxyPassReverse appropriate, or could they be causing the problem? I want the domains listed in the .conf file to serve up the content running on the Gunicorn server on 8000.

share|improve this question
    
look in author.cjshayward.error.log not /var/log/apache2/error.log. –  Zoredache Jan 14 at 16:14
1  
If you have an answer, please post it as such and then accept your own answer so this question doesn't hang "in limbo" for eternity. :) –  EEAA Jan 14 at 16:55
add comment

1 Answer

[Tue Jan 14 16:38:37.054643 2014] [proxy:warn] [pid 12715] [client 98.253.179.182:58922] AH01144: No protocol handler was valid for the URL /. If you are using a DSO version of mod_proxy, make sure the proxy submodules are included in the configuration using LoadModule.
[Tue Jan 14 16:38:38.991741 2014] [proxy:warn] [pid 12619] [client 98.253.179.182:58923] AH01144: No protocol handler was valid for the URL /favicon.ico. If you are using a DSO version of mod_proxy, make sure the proxy submodules are included in the configuration using LoadModule.

A search for the error message turned up http://stackoverflow.com/questions/17475587/setup-mod-proxy-on-apache-http-server , and I'm off to ordinary Django debugging after enabling proxy_http.load.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.