Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This is my first post, so please be gentle. :)

My CentOS 6.5 box has a QEMU binary that does not support live external snapshots. This is the command I attempt on the virsh CLI, and its output:

virsh # snapshot-create-as myvm snapshot1 "snapshot1 test" --disk-only --atomic
error: Operation not supported: live disk snapshot not supported with this QEMU binary

First Question: Which QEMU binary is this error referring to?

I assumed that the QEMU binary referenced was /usr/libexec/qemu-kvm.

Second Question: How should the QEMU binary be updated when it isn't available in the operating system's package management system?

I attempted to download the source of a newer version at http://sourceforge.net/projects/kvm/files/qemu-kvm/1.2.0/, compile it, and create a symbolic link that points to the appropriate binary. A listing of the link looks like so:

/usr/local/bin # ls -lah /usr/libexec/qemu-kvm
lrwxrwxrwx 1 root root 33 Jan 14 11:20 /usr/libexec/qemu-kvm -> /usr/local/bin/qemu-system-x86_64

I then restarted libvirtd, but I'm getting the same error.

Any help is much appreciated!

share|improve this question
    
If you run virsh qemu-monitor-command myvm '{"execute":"query-commands"}' does the output include "snapshot_blkdev"? –  sciurus Jan 14 at 21:40
    
Also, did you restart your VM after creating the qemu symlink? –  sciurus Jan 14 at 21:44
    
@sciurus Ah, restarting the VM was the issue! The process from the old binary was still running. I also had to run virsh edit myvm and change the 'machine' setting from 'rhel6.5.0' to 'pc-1.2', then the VM restarted like a charm. Thank you! –  billyw Jan 14 at 22:39
    
Okay, I'll add restarting as an answer then. –  sciurus Jan 15 at 0:32

1 Answer 1

up vote 3 down vote accepted

You need to restart your VM for it to use the new version of qemu.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.