Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have configured WDS to deploy a Windows 7 Pro image (Volume Licensed) and I'm using an unattend.xml file for the configuration. The only problem I'm running into is activation. I'm passing a MAK Volume License key in the unattend.xml file but after the image gets pulled down from the server and it installs and the machine reboots, not only does it NOT activate but the license key specified in the unattend.xml file doesn't appear; a totally different license key is there (in My Computer in the license/activation section on the bottom).

I'm entering the product key in the correct spot in the unattend.xml file (or so I'm led to believe from Microsoft's documentation) so I'm not sure what's wrong?

share|improve this question
    
How are you attaching the unattend file? Are you embedding it in the image, or attaching it in WDS? It’s possible that the system is using a different unattend file based on implicit search order. Is there anything in the log files that might help? Also, you are installing Windows 7 pro x86, right? –  WinOutreach4 Jan 22 at 19:14
    
It's Windows 7 Pro x64 that I'm installing. The file is being attached via WDS. I know the file is being read and working properly as everything else in the file BUT the MAK activation is working. Nothing in log files. –  MisterMike Jan 23 at 2:20
add comment

1 Answer

From the Picture that you posted, you are adding the x86_Microsoft-Windows-Shell-Setup node, and not the x64_Microsoft-Windows-Shell-Setup to your unattend file. Changing this to the appropriate architecture should solve this problem.

Hope this helps,

share|improve this answer
    
Sorry, that picture was just for reference to what the option is and what pass it's being added to (not for the architecture). I'm using the proper architecture. –  MisterMike Jan 24 at 1:07
    
@mistermike You can enter the proper key using an elevated command prompt and the command “slmgr.vbs /ipk <your kms key>”? You can then force activation with “slmgr.vbs –ato”. If running the command manually works, you can script it and add it to the unattend file. Do you have enough clients activating to exceed the KMS minimums (25 for Windows 7)? –  WinOutreach4 Jan 24 at 13:47
    
So there's no way to pass in the key and make it activate without running something extra? I feel like solutions such as those are "workarounds" and while they work aren't what was intended for the product. –  MisterMike Jan 29 at 3:43
    
@MisterMike I supplied the work around in case this was a time-sensitive issue. Is this an Image Unattend file? Are you re-attaching the file to the image each time you make changes? I ask because when you attach the unattend to an image, it makes a copy of the unattend in a subfolder under the specific image folder and renames it to ImageUnattend.xml, so changes you make to the original file do not get used unless you re-attach the file after each change. –  WinOutreach4 Jan 29 at 20:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.