Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have Centos 5.10 installed on my server and tried running the following command

yum install php53u-pecl-memcached.x86_64
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php53u-pecl-memcached.x86_64 0:1.0.0-3.ius.centos5 set to be updated
--> Processing Dependency: php53u-zend-abi = 20090626 for package: php53u-pecl-memcached
--> Processing Dependency: libmemcached.so.2(libmemcached_2)(64bit) for package: php53u-pecl-memcached
--> Processing Dependency: libmemcached.so.2()(64bit) for package: php53u-pecl-memcached
--> Running transaction check
---> Package php53u-common.x86_64 0:5.3.28-1.ius.centos5 set to be updated
---> Package php53u-pecl-memcached.x86_64 0:1.0.0-3.ius.centos5 set to be updated
--> Processing Dependency: libmemcached.so.2(libmemcached_2)(64bit) for package: php53u-pecl-memcached
--> Processing Dependency: libmemcached.so.2()(64bit) for package: php53u-pecl-memcached
--> Processing Conflict: php53-common conflicts php-common
--> Finished Dependency Resolution
php53-common-5.3.3-22.el5_10.x86_64 from installed has depsolving problems
  --> php53-common conflicts with php53u-common
php53u-pecl-memcached-1.0.0-3.ius.centos5.x86_64 from ius has depsolving problems
  --> Missing Dependency: libmemcached.so.2()(64bit) is needed by package php53u-pecl-memcached-1.0.0-3.ius.centos5.x86_64 (ius)
php53u-pecl-memcached-1.0.0-3.ius.centos5.x86_64 from ius has depsolving problems
  --> Missing Dependency: libmemcached.so.2(libmemcached_2)(64bit) is needed by package php53u-pecl-memcached-1.0.0-3.ius.centos5.x86_64 (ius)
Error: php53-common conflicts with php53u-common
Error: Missing Dependency: libmemcached.so.2(libmemcached_2)(64bit) is needed by package php53u-pecl-memcached-1.0.0-3.ius.centos5.x86_64 (ius)
Error: Missing Dependency: libmemcached.so.2()(64bit) is needed by package php53u-pecl-memcached-1.0.0-3.ius.centos5.x86_64 (ius)

So I get a few error regarding php conflicts and missing dependencies.

php53-common conflicts php-common
php53-common conflicts with php53u-common

Trying to remove packages

yum remove php-common
yum remove php53-common

Both command result in

Package(s) php-common available, but not installed.
Package(s) php53u-common available, but not installed.
No Packages marked for removal

How can there be a conflict if the package is not installed? I can remove php53-common, but this will also remove the dependencies, which is a pleks installation and I don't want to remove that.

What is the best thing I can do now?

share|improve this question

2 Answers 2

Maybe was installed manually from source or using an rpm possibly?

Try the following for example..

rpm -qa php-common

rpm -qa php53-common

Then try removing by doing the following...

sudo rpm -e `rpm -qa | grep -i php-common `

sudo rpm -e `rpm -qa | grep -i php53-common `

If it was installed from source for some crazy reason then you might have a battle on your hands!

Good luck :)

share|improve this answer
1  
Thnx! I got the conflicts resolved so far. I removed all php packages and installed php53u. Then i reinstalled plesk and ignored the php53 support because plesk otherwise removed the php53u version. I only have the libmemcached.so.2 dependency error left. –  Maykel Boes Jan 16 at 13:20

libmemcached.so.2 is provided by libmemcached

see the following

[mike@mem01-east ~]$ rpm -qf /usr/lib64/libmemcached.so.2
libmemcached-0.31-1.1.el6.x86_64
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.