Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to make an SSL wrapper to a website (and eventually redirect all HTTP requests to the HTTPS domain), on a Saucy EC2 instance. Right now Apache restarts without reported error, and it serves up the HTTP requests at as (for now) intended, but an attempted SSL connection doesn't respond. This is, at present, the only (attempt at) a site on this computer delivered via HTTPS instead of HTTP.

My VirtualHost config file, ssl.conf, is:

#NameVirtualHost *:443

<VirtualHost *:443>
    ServerName pragmatometer.com

    DocumentRoot /home/jonathan/mirror/professional
    ErrorLog /var/log/apache2/error.log
    CustomLog /var/log/apache2/access.log combined

     SSLEngine On
     SSLCertificateFile /etc/apache2/ssl/ssl.crt
     SSLCertificateKeyFile /etc/apache2/ssl/ssl.key
    ServerAlias www.pragmatometer.com analyticalnoticeboard.com www.analyticalnoticeboard.com logisticmvc.com www.logisticmvc.com
    ServerAdmin CJSHayward@PObox.com

    DocumentRoot /home/jonathan/classicorthodoxbible.com
    <Directory />
        Options FollowSymLinks
        AllowOverride None
    </Directory>
    <Directory /var/www/>
        Options ExecCGI Indexes FollowSymLinks MultiViews
        AllowOverride None
        Order allow,deny
        allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
        AllowOverride None
        Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
        Order allow,deny
        Allow from all
    </Directory>

    ErrorLog ${APACHE_LOG_DIR}/author.cjshayward.error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    CustomLog ${APACHE_LOG_DIR}/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all

        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

    Alias /media/ /home/jonathan/pragmatometer/media/

    ProxyPass /media/ !
    ProxyPass / http://localhost:8000/
    ProxyPassReverse / http://localhost:8000/

</VirtualHost>

My certificate is from StartSSL.

Does any of this suggest why attempted HTTPS connections hang?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Several things to check:

  • Did you open port 443 in the security context for the EC2 instance?
  • Do you firewall port 443 on the instance itself?
  • Is Apache listening on port 443? (You can check with netstat -nlp)
    • If not, you need to add a Listen 443 directive in your global Apache config.

Hope this helps!

share|improve this answer
1  
"Did you open port 443 in the security context?" - I did now, and it's working now. Thanks, –  Jonathan Hayward Jan 16 at 16:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.