Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

So I just noticed this issue, and it's rather urgent we find a solution, it's literally been ongoing unnoticed several days, as any communication being sent to us from our email forms and offer forms on the site are essentially going into a black hole.

We just did a change from Shared to a VPS. Have been using Google Apps Gmail all along.

Not sure if this is a misconfigured DNS or what but it's odd that every possible way of sending and receiving mail works, except when the server sends mail to emails with the @domain.com's email address.

Does anyone perhaps know what can cause this issue? Or a way to debug it? It'd be greatly appreciated!

share|improve this question
1  
First check the server's logs. –  Michael Hampton Jan 17 at 1:44

2 Answers 2

up vote 2 down vote accepted

Your new VPS might have an email service installed & configured in such a way that it think it is authoritative for @domain.com - so it's not relaying any emails toward your Google Apps account.

An easy way to confirm would be to check /var/log/maillog (or /var/log/mail).

The exact Plesk (Parallel) knowledge base article to fix your problem is here: http://kb.parallels.com/en/116927. Here's a repost of the interesting extract:

Disable mail service for the domain.tld subscription:
Go to Subscriptions > domain.tld > Mail > Change Settings.
Uncheck Activate mail service on domain and click OK.

You may also disable mail service on the subscription using the command-line utility mail:
/usr/local/psa/bin/mail --off domain.tld
share|improve this answer
    
Thanks Cloud! This did the trick :) Whew.............. :D –  Z with a Z Jan 17 at 3:18
    
Now it's an entirely different issue figuring out where all that other mail went off to.. fun fun –  Z with a Z Jan 17 at 3:19
    
The other mail should have been bounced back to sender because recipient didn't exist - which mean yourself, which should mean postmaster, which should mean root on the box). I would suggest looking into /var/mail/root (or /var/spool/mail/root) file. –  CloudWeavers Jan 19 at 22:11

If your server hostname is in the same domain, your email will try to go to local users. You have to configure mail sender correctly.

Example: mailserver.example.com

  • Email sent from this server to XXX@example.com will go to local user mailbox.

You can refere to this post on how disable local delivery

share|improve this answer
1  
Thank you for your input. –  Z with a Z Jan 17 at 3:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.