Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I tried to re-add a restored VM to AD-domain to restore the trust relationship. However, I cannot change the workgroup/domain via Computer > Properties. There's an error message which says that C:\Windows\system32\netid.dll is broken and the "Computername" tab is not present in System Settings.

I ran SFC and it says the file is corrupt but can't repair it, and I didn't manage to replace it manually due to insufficient permissions. Using WMIC and "JoinDomainOrWorkgroup" also didn't work.

Is there any other way to fix this DLL / change the workgroup/domain membership / re-add the computer to the domain or restore the trust relationship?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I was now able to gain access to the DLL and replace with one from another machine with an equivalent operating system using these commands:

takeown /f C:\Windows\System32\netid.dll
cacls C:\Windows\System32\netid.dll /G Administrator:F

Source:

http://www.howtogeek.com/howto/windows-vista/how-to-delete-a-system-file-in-windows-vista/

It's working now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.