Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i have a solaris server with 40tb of data on it that i need to get moved to another linux server. i bought 2 qlogic fiber cards both are qle2462 and put one in the solaris box and the other in the linux box. so i need to put the linux box in target mode somehow and then push the data over to it. literature is hard to find does anyone have even a general overview of IF this is possible and if so how to put a qle2462 card in target mode on redhat?

share|improve this question
    
Why do you need to use fiber for transferring the data between two systems? That's what your network interfaces are for. –  yoonix Jan 17 at 21:01
    
1gb gets me about 1.5 TB per day. i cant hammer away at my ZFS server for 20 days. in hindsight i certainly should have just moved it a little at a time though, since i have spent 2 weeks or better struggling with LACP and fiber/infiniband...using a SAN technology ala carte on a small scale is far from feasible. lesson learned there –  RonFish Jan 18 at 23:59
    
@RonFish I can't follow your calculation. Why is 1 Gbps just allowing you to transfer 1.5 TB in 24 hours? You should get around 10 TB. And there of course is the option of using 10GBE copper too if you can get the two machines close enough to each other. –  the-wabbit Feb 2 at 21:46
    
thats the theoterical maximum for 1gb...128MBps...i can top out at around 75 but wont hold steady. i run ZFS and the sun box is at 95% capacity. with processor/disk lag it ends up being around 50. –  RonFish Feb 4 at 1:10
    
If you end up with 50 MB/s, the bottleneck is likely not the network but the I/O subsystem. Try disabling atimes on your ZFS datasets and enabling metaslab debugging if the Solaris box is seeing write load while you're trying to copy. You also might try just hooking up the ZFS vdevs to your Redhat machine and use ZFS on Linux to access/copy the data without networking bandwidth constraints. –  the-wabbit Feb 4 at 10:05

2 Answers 2

By default the qla2xxx driver is set to initiator mode, so you need to enable the target mode with a module parameter qlini_mode

You should have something like:

options qla2xxx qlini_mode="disabled"

in your /etc/modprobe.d/qla2xxx.conf (module config) You can also check the mode with

cat /sys/module/qla2xxx/parameters/qlini_mode

look for qla2xxx qlini_mode in google

share|improve this answer

You also could do it the other way around and put the Solaris box into target mode. In this case, the qlc module loaded by default has to be replaced by the target variant called qlt using update_drv. Reference: http://docs.oracle.com/cd/E23824_01/html/821-1459/glddq.html

How to Set All FC Ports to a Specific Mode

Display what is currently bound to the port drivers.

In this example, the current binding is pciex1077,2432.

# mdb -k
Loading modules: [ unix krtld genunix specfs ...
> ::devbindings -q qlc
30001617a08 pciex1077,2432, instance #0 (driver name: qlc)
300016177e0 pciex1077,2432, instance #1 (driver name: qlc)
> $q

Remove the current binding.

In this example, the qlc driver is actively bound to pciex1077,2432. You must remove the existing binding for qlc before you can add that binding to a new driver. Single quotation marks are required in this syntax.

# update_drv -d -i 'pciex1077,2432' qlc
Cannot unload module: qlc

Establish the new binding.

In this example, qlt is updated. Single quotes are required in this syntax.

# update_drv -a -i 'pciex1077,2432' qlt
devfsadm: driver failed to attach: qlt
Warning: Driver (qlt) successfully added to system but failed to attach
    Will be unloaded upon reboot.

Reboot the system to attach the new driver.

share|improve this answer
    
i gave up on fiber and grabbed some mellanox infiniband cards. then i ran into the limitations of solaris 10 5/08...maybe i should put the fiber back in and try the above. but then i have a infiniband switch coming too which would give me a subnet manager. like i said, SAN is far from trivial and if i were gonna stick with it solaris 10 would go bye bye –  RonFish Feb 4 at 1:13
    
@RonFish oh, 5/08. Not sure if it even would allow you to run an FC target. COMSTAR allows you for serving an FC target on from Solaris 11, I never tried anything even remotely similar on 10. –  the-wabbit Feb 4 at 9:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.