Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a small VPS that I'm trying to upgrade. The initial version of Ubuntu was 12.04. Since I had some issues I was suggested to try to upgrade to see if the problem persists. So I started first to do-release-upgrade to 12.10. The process finished ok and there were no problems reported. But now, when I try to run again do-release-upgrade in order to upgrade to 13.04, each time the process ends with an error saying that it could not calculate the upgrade, the final error being that "you have held broken packages".

Now, I don't know why and how this could have happened. The only thing that I did not do during the first upgrade was to configure dhcp6client (or something like that). It asked for the network interface to use, didn't know it, so I let it blank.

During the second upgrade process, there are a lot of Err type of prefixes that show up when fetching repositories, like this:

enter image description here

or this:

enter image description here

I searched a little bit on the web to see what holding broken packages means, and it appears that there are quite a few actually when i run the grep Broken /var/log/dist-upgrade/apt.log command:

Broken tar:amd64 PreDepends on libc6 [ amd64 ] < 2.15-0ubuntu10+openvz0 -> 2.17-0ubuntu5.1 > ( libs ) (>= 2.17)
Broken diffutils:amd64 PreDepends on libc6 [ amd64 ] < 2.15-0ubuntu10+openvz0 -> 2.17-0ubuntu5.1 > ( libs ) (>= 2.17)
Broken libtinfo5:amd64 Depends on libc6 [ amd64 ] < 2.15-0ubuntu10+openvz0 -> 2.17-0ubuntu5.1 > ( libs ) (>= 2.16)
Broken libstdc++6:amd64 Depends on libc6 [ amd64 ] < 2.15-0ubuntu10+openvz0 -> 2.17-0ubuntu5.1 > ( libs ) (>= 2.17)
Broken libapt-pkg4.12:amd64 Depends on libstdc++6 [ amd64 ] < 4.7.2-2ubuntu1 -> 4.7.3-1ubuntu1 > ( libs ) (>= 4.6)
Broken libncurses5:amd64 Depends on libtinfo5 [ amd64 ] < 5.9-10ubuntu1 -> 5.9-10ubuntu4 > ( libs ) (= 5.9-10ubuntu4)
Broken libdb5.1:amd64 Depends on libc6 [ amd64 ] < 2.15-0ubuntu10+openvz0 -> 2.17-0ubuntu5.1 > ( libs ) (>= 2.17)
Broken libssl1.0.0:amd64 Depends on libc6 [ amd64 ] < 2.15-0ubuntu10+openvz0 -> 2.17-0ubuntu5.1 > ( libs ) (>= 2.17)
Broken apt-utils:amd64 Depends on libapt-pkg4.12 [ amd64 ] < 0.9.7.5ubuntu5.6 -> 0.9.7.7ubuntu6 > ( admin ) (>= 0.8.16~exp9)
Broken libncursesw5:amd64 Depends on libtinfo5 [ amd64 ] < 5.9-10ubuntu1 -> 5.9-10ubuntu4 > ( libs ) (= 5.9-10ubuntu4)
Broken upstart:amd64 Depends on libudev1 [ amd64 ] < none -> 198-0ubuntu11.2 > ( libs ) (>= 183)
Broken mountall:amd64 Depends on libudev1 [ amd64 ] < none -> 198-0ubuntu11.2 > ( libs ) (>= 183)
Broken libapt-inst1.5:amd64 Depends on libapt-pkg4.12 [ amd64 ] < 0.9.7.5ubuntu5.6 -> 0.9.7.7ubuntu6 > ( admin ) (>= 0.8.16~exp9)
Broken udev:amd64 Depends on libc6 [ amd64 ] < 2.15-0ubuntu10+openvz0 -> 2.17-0ubuntu5.1 > ( libs ) (>= 2.17)
Broken libkrb5-3:amd64 Depends on libc6 [ amd64 ] < 2.15-0ubuntu10+openvz0 -> 2.17-0ubuntu5.1 > ( libs ) (>= 2.16)
Broken python3-minimal:amd64 Depends on python3.3-minimal [ amd64 ] < none -> 3.3.1-1ubuntu5.2 > ( python ) (>= 3.3.1-1~)
Broken python3.3:amd64 Depends on python3.3-minimal [ amd64 ] < none -> 3.3.1-1ubuntu5.2 > ( python ) (= 3.3.1-1ubuntu5.2)
Broken initramfs-tools-bin:amd64 Depends on libudev1 [ amd64 ] < none -> 198-0ubuntu11.2 > ( libs ) (>= 183)
Broken python3-apt:amd64 Depends on libapt-inst1.5 [ amd64 ] < 0.9.7.5ubuntu5.6 -> 0.9.7.7ubuntu6 > ( admin ) (>= 0.8.11)
Broken libdrm2:amd64 Depends on libc6 [ amd64 ] < 2.15-0ubuntu10+openvz0 -> 2.17-0ubuntu5.1 > ( libs ) (>= 2.17)
Broken libglib2.0-0:amd64 Depends on libc6 [ amd64 ] < 2.15-0ubuntu10+openvz0 -> 2.17-0ubuntu5.1 > ( libs ) (>= 2.17)
Broken python3-distupgrade:amd64 Depends on python3-apt [ amd64 ] < 0.8.7ubuntu4.1 -> 0.8.8ubuntu6 > ( python ) (>= 0.8.5~)
Broken python3-update-manager:amd64 Depends on python3-apt [ amd64 ] < 0.8.7ubuntu4.1 -> 0.8.8ubuntu6 > ( python ) (>= 0.8.5~)
Broken libdns95:amd64 Depends on libkrb5-3 [ amd64 ] < 1.10.1+dfsg-2 -> 1.10.1+dfsg-4+nmu1 > ( libs ) (>= 1.6.dfsg.2)
Broken python2.7-minimal:amd64 Depends on libc6 [ amd64 ] < 2.15-0ubuntu10+openvz0 -> 2.17-0ubuntu5.1 > ( libs ) (>= 2.16)
Broken libasprintf0c2:amd64 Depends on libstdc++6 [ amd64 ] < 4.7.2-2ubuntu1 -> 4.7.3-1ubuntu1 > ( libs ) (>= 4.1.1)
Broken libpython2.7-minimal:amd64 Breaks on python2.7-minimal [ amd64 ] < 2.7.3-5ubuntu4.3 -> 2.7.4-2ubuntu3.2 > ( python ) (< 2.7.4~rc1-1~)
Broken python-apt:amd64 Depends on libapt-inst1.5 [ amd64 ] < 0.9.7.5ubuntu5.6 -> 0.9.7.7ubuntu6 > ( admin ) (>= 0.8.11)
Broken groff-base:amd64 Depends on libstdc++6 [ amd64 ] < 4.7.2-2ubuntu1 -> 4.7.3-1ubuntu1 > ( libs ) (>= 4.1.1)
Broken libisccfg90:amd64 Depends on libdns95 [ amd64 ] < none -> 1:9.9.2.dfsg.P1-2ubuntu2.2 > ( libs )
Broken ubuntu-release-upgrader-core:amd64 Depends on python3-distupgrade [ amd64 ] < 1:0.190.8 -> 1:0.192.13 > ( python ) (= 1:0.192.13)
Broken libsigc++-2.0-0c2a:amd64 Depends on libstdc++6 [ amd64 ] < 4.7.2-2ubuntu1 -> 4.7.3-1ubuntu1 > ( libs ) (>= 4.6)
Broken libxapian22:amd64 Depends on libstdc++6 [ amd64 ] < 4.7.2-2ubuntu1 -> 4.7.3-1ubuntu1 > ( libs ) (>= 4.6)
Broken libpython2.7:amd64 Depends on libc6 [ amd64 ] < 2.15-0ubuntu10+openvz0 -> 2.17-0ubuntu5.1 > ( libs ) (>= 2.16)
Broken gettext-base:amd64 Depends on libasprintf0c2 [ amd64 ] < 0.18.1.1-9ubuntu1 -> 0.18.1.1-10ubuntu3 > ( libs ) (>= 0.18.1.1-6)
Broken telnet:amd64 Depends on libstdc++6 [ amd64 ] < 4.7.2-2ubuntu1 -> 4.7.3-1ubuntu1 > ( libs ) (>= 4.1.1)
Broken aptitude:amd64 Depends on libapt-pkg4.12 [ amd64 ] < 0.9.7.5ubuntu5.6 -> 0.9.7.7ubuntu6 > ( admin ) (>= 0.9.3)
Broken fetchmail:amd64 Depends on libkrb5-3 [ amd64 ] < 1.10.1+dfsg-2 -> 1.10.1+dfsg-4+nmu1 > ( libs ) (>= 1.6.dfsg.2)
Broken libcwidget3:amd64 Depends on libsigc++-2.0-0c2a [ amd64 ] < 2.2.10-0.2 > ( libs ) (>= 2.0.2)
Broken libboost-iostreams1.49.0:amd64 Depends on libstdc++6 [ amd64 ] < 4.7.2-2ubuntu1 -> 4.7.3-1ubuntu1 > ( libs ) (>= 4.2.1)
Broken update-manager-core:amd64 Depends on python3-update-manager [ amd64 ] < 1:0.174.4 -> 1:0.186.2 > ( python ) (= 1:0.186.2)
Broken python-xapian:amd64 Depends on libstdc++6 [ amd64 ] < 4.7.2-2ubuntu1 -> 4.7.3-1ubuntu1 > ( libs ) (>= 4.1.1)
Broken apt-xapian-index:amd64 Depends on python-xapian [ amd64 ] < 1.2.12-2 > ( python ) (>= 1.0.2)
Broken libbind9-90:amd64 Depends on libdns95 [ amd64 ] < none -> 1:9.9.2.dfsg.P1-2ubuntu2.2 > ( libs )
Broken man-db:amd64 Depends on groff-base [ amd64 ] < 1.21-9 -> 1.22.1-3 > ( text ) (>= 1.18.1.1-15)
Broken libept1.4.12:amd64 Depends on libapt-pkg4.12 [ amd64 ] < 0.9.7.5ubuntu5.6 -> 0.9.7.7ubuntu6 > ( admin ) (>= 0.8.16~exp9)
Broken unattended-upgrades:amd64 Depends on python3-apt [ amd64 ] < 0.8.7ubuntu4.1 -> 0.8.8ubuntu6 > ( python ) (>= 0.7.90)
Broken libgomp1:amd64 Depends on libc6 [ amd64 ] < 2.15-0ubuntu10+openvz0 -> 2.17-0ubuntu5.1 > ( libs ) (>= 2.17)
Broken libapt-pkg-perl:amd64 Depends on libapt-pkg4.12 [ amd64 ] < 0.9.7.5ubuntu5.6 -> 0.9.7.7ubuntu6 > ( admin ) (>= 0.8.0)
Broken openssh-server:amd64 Depends on libc6 [ amd64 ] < 2.15-0ubuntu10+openvz0 -> 2.17-0ubuntu5.1 > ( libs ) (>= 2.16)
Broken libasprintf-dev:amd64 Depends on libasprintf0c2 [ amd64 ] < 0.18.1.1-9ubuntu1 -> 0.18.1.1-10ubuntu3 > ( libs ) (= 0.18.1.1-10ubuntu3)
Broken bind9utils:amd64 Depends on libbind9-90 [ amd64 ] < none -> 1:9.9.2.dfsg.P1-2ubuntu2.2 > ( libs )
Broken python-software-properties:amd64 Depends on python-apt [ amd64 ] < 0.8.7ubuntu4.1 -> 0.8.8ubuntu6 > ( python ) (>= 0.6.20ubuntu16)
Broken procinfo:amd64 Depends on libstdc++6 [ amd64 ] < 4.7.2-2ubuntu1 -> 4.7.3-1ubuntu1 > ( libs ) (>= 4.4.0)
Broken gettext:amd64 Depends on libgomp1 [ amd64 ] < 4.7.2-2ubuntu1 -> 4.7.3-1ubuntu1 > ( libs ) (>= 4.2.1)
Broken apt-show-versions:amd64 Depends on libapt-pkg-perl [ amd64 ] < 0.1.26 > ( perl ) (>= 0.1.21)
Broken libdrm-intel1:amd64 Depends on libc6 [ amd64 ] < 2.15-0ubuntu10+openvz0 -> 2.17-0ubuntu5.1 > ( libs ) (>= 2.17)
Broken binutils:amd64 Depends on libstdc++6 [ amd64 ] < 4.7.2-2ubuntu1 -> 4.7.3-1ubuntu1 > ( libs ) (>= 4.6)
Broken dselect:amd64 Depends on libstdc++6 [ amd64 ] < 4.7.2-2ubuntu1 -> 4.7.3-1ubuntu1 > ( libs ) (>= 4.1.1)
Broken apt:amd64 Depends on libapt-pkg4.12 [ amd64 ] < 0.9.7.5ubuntu5.6 -> 0.9.7.7ubuntu6 > ( admin ) (>= 0.9.7.7ubuntu6)
Broken python3:amd64 Depends on python3.3 [ amd64 ] < none -> 3.3.1-1ubuntu5.2 > ( python ) (>= 3.3.1-1~)
Broken python2.7:amd64 Depends on python2.7-minimal [ amd64 ] < 2.7.3-5ubuntu4.3 -> 2.7.4-2ubuntu3.2 > ( python ) (= 2.7.4-2ubuntu3.2)
Broken libgssapi-krb5-2:amd64 Depends on libkrb5-3 [ amd64 ] < 1.10.1+dfsg-2 -> 1.10.1+dfsg-4+nmu1 > ( libs ) (= 1.10.1+dfsg-4+nmu1)
Broken python-minimal:amd64 Depends on python2.7-minimal [ amd64 ] < 2.7.3-5ubuntu4.3 -> 2.7.4-2ubuntu3.2 > ( python ) (>= 2.7.4-1~)
Broken initramfs-tools:amd64 Depends on initramfs-tools-bin [ amd64 ] < 0.103ubuntu0.2.1 -> 0.103ubuntu0.8 > ( utils ) (>= 0.103ubuntu0.8)
Broken libpython2.7-stdlib:amd64 Depends on libpython2.7-minimal [ amd64 ] < none -> 2.7.4-2ubuntu3.2 > ( python ) (= 2.7.4-2ubuntu3.2)
Broken vim:amd64 Depends on libpython2.7 [ amd64 ] < 2.7.3-5ubuntu4.3 -> 2.7.4-2ubuntu3.2 > ( libs ) (>= 2.7)
Broken libdns81:amd64 Depends on libgssapi-krb5-2 [ amd64 ] < 1.10.1+dfsg-2 -> 1.10.1+dfsg-4+nmu1 > ( libs ) (>= 1.10+dfsg~)
Broken openssh-client:amd64 Depends on libgssapi-krb5-2 [ amd64 ] < 1.10.1+dfsg-2 -> 1.10.1+dfsg-4+nmu1 > ( libs ) (>= 1.10+dfsg~)
Broken libbind9-80:amd64 Depends on libdns81 [ amd64 ] < 1:9.8.1.dfsg.P1-4.2ubuntu3.4 > ( libs )
Broken libisccfg82:amd64 Depends on libdns81 [ amd64 ] < 1:9.8.1.dfsg.P1-4.2ubuntu3.4 > ( libs )
Broken bind9utils:amd64 Depends on libbind9-80 [ amd64 ] < 1:9.8.1.dfsg.P1-4.2ubuntu3.4 > ( libs )
Broken libcups2:amd64 Depends on libgssapi-krb5-2 [ amd64 ] < 1.10.1+dfsg-2 -> 1.10.1+dfsg-4+nmu1 > ( libs ) (>= 1.10+dfsg~)
Broken python:amd64 Depends on python2.7 [ amd64 ] < 2.7.3-5ubuntu4.3 -> 2.7.4-2ubuntu3.2 > ( python ) (>= 2.7.4-1~)
Broken libpython-stdlib:amd64 Depends on libpython2.7-stdlib [ amd64 ] < none -> 2.7.4-2ubuntu3.2 > ( python ) (>= 2.7.4-1~)
Broken libudev1:amd64 Depends on libc6 [ amd64 ] < 2.15-0ubuntu10+openvz0 -> 2.17-0ubuntu5.1 > ( libs ) (>= 2.17)

Also, /etc/apt/sources.lst has the following sources:

deb http://archive.ubuntu.com/ubuntu quantal main restricted universe
deb http://archive.ubuntu.com/ubuntu quantal-updates main restricted universe
deb http://security.ubuntu.com/ubuntu quantal-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu quantal partner

I've tried doing apt-get update && apt-get upgrade or to autoremove/autoclean (even apt-get install -f that I saw someone recommending), but without success, every time I get that 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded and the problem still persists. Honestly I don't know how come those packages are listed as broken.

Can anyone help me with this issue ?

p.s. sorry for the long post but I wanted to include all the details that I thought worth knowing

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.