Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Currently I am running bugzilla 4.2 with Testopia 2.5 on Apache2, Perl 5.14. Mysql 5.5. I tried to follow the Bugzilla REST API but it showed errors when I tried to start the server BzApi, in # script/

Compilation failed in require at /usr/local/share/perl/5.14.2/Module/ line 317. at /usr/local/share/perl/5.14.2/Catalyst/Script/ line 238.

For the Kanbanzilla installation I followed the steps as shown here; in file under server folder I updated the login url to my bugzilla installation ( and bugzilla_url to

I was successfully logged in with bugzilla admin account via Kanbanzilla but when I click on create new board, I am getting a 500 error.

I am 100% sure that I made some mistake in configuration. I hope some one has a solution for this.

Thanks in Advance.

share|improve this question

Not permitted to comment, so:

Compilation failed in require at /usr/local/share/perl/5.14.2/Module/ line 317. at /usr/local/share/perl/5.14.2/Catalyst/Script/ line 238.

What are those two lines of code?

If you can't get BzAPI running, then obviously Kanbanzilla isn't going to work. So focus on getting BzAPI running first. I've no idea why it doesn't start, but you need to track down what is failing to compile properly.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.