Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running postfix on debian wheezy with Dovecot and I had spam issues with a php script . after finding and removing the script I am unable to send any mails from squirrel mail from my browser. I get

ERROR: Message not sent. Server replied: Service not available, closing channel 421 4.3.2 All server ports are busy

How can i track this issue down and What information should I provide to resolve this issue?

thanks

share|improve this question
    
Please check your /var/log/mail.log or /var/log/maillog –  b13n1u Jan 19 at 9:39
    
Jan 19 13:06:54 htz postfix/postscreen[10888]: warning: cannot connect to service private/smtpd: No such file or directory Jan 19 13:06:55 htz postfix/postscreen[10888]: PASS NEW [64.20.227.133]:62525 Jan 19 13:06:55 htz postfix/postscreen[10888]: DISCONNECT [64.20.227.133]:62525 Jan 19 13:08:35 htz postfix/postscreen[10888]: close database /var/lib/postfix/postscreen_cache.db: No such file or directory (possible Berkeley DB bug) –  user3067037 Jan 19 at 9:45
    
I guess you have already tried to restart postfix ?:) Please share the output of postconf -n –  b13n1u Jan 19 at 9:49
    
I don't even have enough rep to copy the output but mxtoolbox.com tells me this : Connecting to 178.63.21.220 SendSMTPCommand: You hung up on us after we connected. Please whitelist us. (connection lost) MXTB-PWS3v2 1435ms –  user3067037 Jan 19 at 9:53
    
I also get Jan 19 13:15:01 htz postfix/postscreen[11386]: warning: cannot connect to service private/smtpd: No such file or directory in my mail log –  user3067037 Jan 19 at 9:59

1 Answer 1

up vote 1 down vote accepted

From the data that you provided it looks like you have enabled postscreen but it is not properly configured. The best option is to disable it for now to check if this helps. Please us this howto to disable it. Also from the provided master.cf it looks like you don't have an MTA(dovecot) configured in postfix. Please add dovecot configuration to the master.cf so postfix will now that it has to move the mails to MTA. an example below(you probably will need to modifiy it a little bit)

dovecot unix - n n - - pipe flags=DRhu user=vmail:vmail argv=/usr/lib/dovecot/dovecot-lda -f ${sender} -d ${recipient}

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.