Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just installed centos 6.3 freshly and noticed the following:

[root@localhost user1]# cat /etc/redhat-release CentOS release 6.3 (Final)

[root@localhost user1]#

[root@localhost user1]# cat /proc/sys/net/core/rmem_max 131071

[root@localhost user1]# cat /proc/sys/net/core/rmem_default 229376

[root@localhost user1]# cat /proc/sys/net/core/wmem_max 131071

[root@localhost user1]# cat /proc/sys/net/core/wmem_default 229376

As you can see rmem_max is "Lesser " than rmem_default and wmem_max is "Lesser" than wmem_default.

As per my knowledge wmem_max and rmem_max should be more than default values ?

EDIT:

# cat /etc/redhat-release CentOS release 6.3 (Final)

# uname -a Linux localhost.localdomain 2.6.32-279.el6.x86_64 #1 SMP Fri Jun 22 12:19:21 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

<< link : https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/7-Beta/html/Performance_Tuning_Guide/s-network-dont-adjust-defaults.html

Bear in mind that the value of rmem_default should be no greater than rmem_max (/proc/sys/net/core/rmem_max); if need be, increase the value of rmem_max.

share|improve this question
    
paste 'uname -a' –  Danila Ladner Jan 20 at 14:32
    
updated kernel version.. –  kumar Jan 22 at 6:17
add comment

1 Answer

up vote 1 down vote accepted

if it is "2.6.32-279" then it is a bug, upgrade it. Should be either equal or more as you mentioned in the link.

share|improve this answer
    
Thanks!..As you mentioned in your Answer, it is 2.6.32-279 only. I see some weird behaviour with UDP burst traffic with these settings..It may be due to these numbers. If you have any additional info. please let me know. –  kumar Jan 22 at 6:15
    
Yes ,because buffers get overflown, upgrade, do not use this kernel, upgrade to 6.4 there is no such thing there, i am not sure where this bug came from in this x.y.z ver –  Danila Ladner Jan 22 at 6:25
    
unfortunately I do not have the luxury to upgrade the kernel..rather, I need to figure out why this is happening..anyway Thanks. –  kumar Jan 22 at 6:39
    
Well then change it to 229376 for {w,r}mem_max and see if you experience the busrts –  Danila Ladner Jan 22 at 6:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.