Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Hoping someone can give me a pointer on here. I recently took a new position and am currently trying to learn the new system. I'm having trouble getting to ASDM and have Googled plenty to no avail.

I can access the ASA via Putty/SSH and see in the config that http server enable is there. One of the networks allowed is the network I'm currently in. My boss can get to it successfully from the same network.

At my previous job I used this all the time and never had any issues, and from what I can tell everything is set up similarly.

When I attempt to get to https://x.x.x.x I get "Connection Refused". It doesn't specify a different port when I do the Sh Run so I believe it is still set to 443.

Any suggestions? Thanks ahead of time!

share|improve this question
1  
Do you have a service contract? Cisco doesn't usually provide their utilities to the public for free. –  Satanicpuppy Jan 21 at 19:31
1  
Try adding http 0.0.0.0 0.0.0.0 $interface to the ASA's config to see if that's the issue (note: replace $interface with the name of your internal interface, commonly "inside"). Also, check your browser for Proxy settings that might be screwing up the connection. –  Chris S Jan 21 at 19:33
    
@Satanicpuppy I don't think he's trying to download ASDM. I think he's trying to get to the ASDM interface on the ASA. –  Chris S Jan 21 at 19:33
    
Correct, the ASA has the image already, I just can't seem to get to it from my machine to run the launcher. I'll look into the proxy settings and try for the 0.0.0.0 addition. Thanks, I'll get back with you all shortly. –  user95917 Jan 21 at 19:40
    
As Chris said, verify what is showing in http <etc>. That's probably the issue. It could be that you're seeing ssh 0.0.0.0 0.0.0.0 inside in the config (allowing you to SSH to it) but not necessarily the same for the http line for ASDM access. –  TheCleaner Jan 21 at 19:48

1 Answer 1

Please check your Java version. If you already have Java 7u51 you need ASDM 7.1.5-100. Downgrade to Java 7u45 for older ASDM versions. In Java 7u51 only WebStart is supported.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.