Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an Intel box with S2600GZ board. I have tried to install a few Linux distros and non can detect the ESRT2 raid. All distros claim "No disks found". My goal is to install OpenSuse 13.

The only distribution I managed to install is Suse Enteprisee 11 SP2 with the help of the Intel Deployment Assistant CD. If I try the stock Suse Enterprise SP2 ISO downloaded as is from the Suse site, I can't detect either. I have to specifically use the Intel CD first.

I also tried downloading the latest drivers from Intel, but can't seem to make OpenSuse load them either. Also the docs seems to point out that the drivers are LSI MegaRaid which I also tried to load the module manually through expert mode.

So what is the Intel deployment CD doing that the stock ISO images aren't? Where can I get some more info for help to debug this?

I also tried to disable ESRT2 all together in the BIOS but still no go. Unless I did something wrong there.

I also posted here pretty much the same questions: https://forums.opensuse.org/showthread.php/494695-Intel-raid-installation-works-on-Suse-Enteprise-11-but-not-Open-Suse-13

share|improve this question
    
'The only distribution I managed to install is Suse Enteprisee 11 SP2 with the help of the Intel Deployment Assistant CD. If I try the stock Suse Enterprise SP2 ISO downloaded as is from the Suse site, I can't detect either. I have to specifically use the Intel CD first.' How did you do this? –  David Alvarez Ortega Oct 29 at 21:17
    
See my answer below... –  user432024 Nov 17 at 16:29

1 Answer 1

up vote 1 down vote accepted

Ok figured it out! I was able to disable ESRT2 FAKE Raid

In Bios

ACHI Controller: Set to ENHANCED

SAS Controller: Set to ESRT not ESRT2

Also make sure to clear the RAID settings if you set anything using the utility provided with BIOS.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.