Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've been scratching my head with this for a while and don't seem to be getting any closer to a solution at the system level. I have asked the same question at SuperUser but so far the answers didn't get me anywhere.

Brief note: A while back I set up an OpenBSD based server to run my websites/dashboard off. The server sits within my company's local network with no external access -- all the connections are blocked by a firewall. Initially -- I had no problems at all; I installed the OS, set up the domain name and everybody could access the server by the name. Recently, I bought a small gigabit switch (D-Link, 5-port) and now I cannot even ping the machine by the name (pinging IP works fine).

I've already tried editing the /etc/hosts file by adding the appropriate information (thought the IP has changed). I also edited the /etc/resolv.conf file. Still, these changes gave me nothing in return. In addition, I followed most of the suggestions from SuperUser.

The dig command (when I select one of the internal DNSs) returns only the AUTHORITY section but no ANSWER section as if my server name was deleted.

The only solution that I found to be working (although it would be really tedious to implement) is to ask all my users (over 100, not all of them can execute a command through cmd) to execute a command that adds to the /etc/hosts file on each local machine (within Windows/System32/drivers folder).

Any help would be truly appreciated as I'm losing it.

Thanks, -Tom

Zone file /var/named/etc/named.conf

// $OpenBSD: named-simple.conf,v 1.10 2009/11/02 21:12:56 jakob Exp $
//
// Example file for a simple named configuration, processing both
// recursive and authoritative queries using one cache.


// Update this list to include only the networks for which you want
// to execute recursive queries. The default setting allows all hosts
// on any IPv4 networks for which the system has an interface, and
// the IPv6 localhost address.
//
acl clients {
        localnets;
        ::1;
};

options {
        version "";     // remove this to allow version queries

        listen-on    { any; };
        listen-on-v6 { any; };

        empty-zones-enable yes;

        allow-recursion { clients; };
};

logging {
        category lame-servers { null; };
};

// Standard zones
//
zone "." {
        type hint;
        file "etc/root.hint";
};

zone "localhost" {
        type master;
        file "standard/localhost";
        allow-transfer { localhost; };
};

zone "127.in-addr.arpa" {
        type master;
        file "standard/loopback";
        allow-transfer { localhost; };
};

zone "1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa" {
        type master;
        file "standard/loopback6.arpa";
        allow-transfer { localhost; };
};


// Master zones
//
//zone "myzone.net" {
//      type master;
//      file "master/myzone.net";
//};

// Slave zones
//
//zone "otherzone.net" {
//      type slave;
//      file "slave/otherzone.net";
//      masters { 192.0.2.1; [...;] };
//};
share|improve this question
    
you need to look at the dns configuration on your local name servers. It sounds like something broke with regard to your host and now local computers can't resolve the ip address from the hostname. Maybe paste a copy of your zone file into your question. –  user16081-JoeT Jan 24 at 0:40
    
I was afraid admin of my network might have 'cleaned it up'... I edited the original question by adding the zone file. –  TDrabas Jan 24 at 3:57
    
thats not a zone file but a named config file. It appears you don't have any zones enabled, so that could be the problem. –  user16081-JoeT Jan 24 at 18:02
    
Thanks. I'll try to enable the zones. Any idea why it would work before and not now, though? That one still baffles me... –  TDrabas Jan 28 at 23:56
1  
I think something must have changed with your internal DNS config, I don't see how introducing a switch could cause name resolution to break. –  user16081-JoeT Jan 29 at 0:02

1 Answer 1

You've got your zones commented out! Uncomment them.

You need to replace:

// Master zones // //zone "myzone.net" { // type master; // file "master/myzone.net"; //}; // Slave zones // //zone "otherzone.net" { // type slave; // file "slave/otherzone.net"; // masters { 192.0.2.1; [...;] }; //};

with:

// Master zones // zone "myzone.net" { type master; file "master/myzone.net"; }; // Slave zones // zone "otherzone.net" { type slave; file "slave/otherzone.net"; masters { 192.0.2.1; [...;] }; };

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.