Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have created a micro instance with Ubuntu OS at Amazon EC2. But I am not able to access public DNS even after installing LAMP Server.

At my apache.conf I can see(no document configuration id available in there) --

# Include the virtual host configurations:
Include sites-enabled/

Inside sites-enabled I have two files -- default & default-ssl.

Default contains

DocumentRoot /var/www
<Directory />
        Options FollowSymLinks
        AllowOverride None
</Directory>
<Directory /var/www/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        Order allow,deny
        allow from all
</Directory>

My apache2 is running at server & /VAR/WWW/ contains a index.php file, where I have written some dummy code for testing.

I tried browsing about it & read somewhere to add a rule in INBOUND for DNS with source 0.0.0.0/0. That also I did, but still when I am trying to access the public DNS it comes "This webpage is not available".

share|improve this question

1 Answer 1

I resolved it by adding HTTP rules in security group of the instance.

Note :- Got help from ##aws IRC channel.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.