Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I run an environment with Server 2003 R2 DC's and mostly WIndows 7 clients with just a few XP clients. The problem I am having is that the Windows 7 PC's are installing updates on their own. We have GPO's set that are suppose to disable this but they still go on. We use WSUS so I want updates to be handed out this way.

Also We use WDS for our image server and when the images are created auto updates are disabled but when they are sysprepped this gets enabled so I suspect that there is something in our Answer file that is causing this as well.

SO my question is, what can I do to be able to fix this problem.

share|improve this question
    
First figure out what your problem is. Use the gpresults to figure out if your Windows Update settings are actually getting to your desktops. Are your GPs being processed without any errors? Check the registry, are the Windows Update settings being configured like you want? –  Zoredache Jan 22 at 23:33
    
Ok so when I look at the update settings on the desktops I go to Windows update, then change settings. There they are grayed out and say configured by your system administrator, but they are set to Install updates automatically.And it wont let me change it even if i'm on my domain admin account. The GPO is suppose to have them disabled, but it doesn't seem like its going through. –  BigCAT41 Jan 23 at 14:46
    
@BigCAT41 That's not what was suggested. Use gpedit and/or rsop to diagnose the problem and determine which GPOs the client is getting. –  HopelessN00b Jan 23 at 15:00
    
I ran rsop and gpresult /Scope User /v. when i ran rsop I did not see any of the windows update GPO's that I have specified. When I looked in gpresult I did see the windows update GP but it was disabled. I browsed to the registry entry and it was not there. SO now that I have it somewhat narrowed down how would I enable it if its set on the server but not on the PC? Also does it mater that these are Windows 7 PC's with a 2003R2 DC? –  BigCAT41 Jan 23 at 15:36
    
@HopelessN00b running rsop and gpedit ending up helping and I was able to figure out the problem. Once I ran rsop I was able to see the GPO causing it, went to the server changed the setting went back to the machine ran gpupdate and rebooted.I know i could of just waited to reboot the machine in 10 minutes but I wanted to make sure it worked –  BigCAT41 Jan 23 at 17:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.