Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a WordPress install on a dedicated server with decent memory (upwards of 8GB).

The WordPress install includes many plugins - 50 active plugins. Most important to note is the WPML plugin to make WordPress multilingual. The theme is Weaver II Pro.

The stack is LAMP - CentOS 6.3, Apache 2.4.4, Percona MySQL, PHP-FPM.

I have been quite stupid, and didn't set up a test or staging server.

Everything was running fine till I updated to WordPress 3.8, and also updated several plugins at the same time.

I didn't pay attention at the time, but all my widgets got messed up, and so did any sort of navigation etc.

I enabled error_log for a bit, i.e.

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . '/error_log.txt');

This resulted in an immense file - basically the error_log grows by about a GB every 4 minutes or so.

The primary error I found in the error log was database server disconnect, better known as

MySQL server has gone away

As suggested at Rackspace, I edited my.cnf to add

wait_timeout = 60

Didn't help.

Also added caching to my.cnf

query_cache_type = 1
query_cache_limit = 8M
query_cache_size = 512M

Didn't help.

(and yes, I restarted mysql every time I edited my.cnf)

Also tried the method suggested here: In wp-db.php before

$this->select( $this->dbname, $this->dbh );

I added

$this->query("set session wait_timeout=600" );

Didn't help.

I'm at my wit's end. Please help!

share|improve this question

1 Answer 1

up vote 1 down vote accepted

does setting max_allowed_packet to something higher help you (in your my.cnf)? Like: max_allowed_packet = 16M

share|improve this answer
    
Did the trick :-) –  OC2PS Jan 27 at 14:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.