Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

User uses a piece of software (simple database and front end app) that connects to a database stored on another workstation, by way of mapped drive. This mode of access is supported by the software vendor and is not a hack in any way.

The problem comes because the 'client' the user uses is a laptop, hence connects to the network via wireless. When the user logs in, the laptop connects to wireless, but the mapped drive hasn't been 'reconnected', so to speak. I don't know the official terminology for this, but suffice it to say that it looks like this:

enter image description here

With the big red X over the drive. Just like the drive in the photo, I can 'double click' the drive in My Computer, and connect to the drive. However, I'd like to avoid submitting that as a 'fix' to the user, as it really isn't a fix. The drive must be 'connected to' before opening the program, or the program won't run.

I thought about using the 'Always Wait for Network at Logon' Group Policy, but I don't know if that applies to wireless (especially since network profiles are user based unless they're added to the group policy), and also since it could cause problems if the laptop isn't in range of a known wireless network.

I tried going into Powershell just now and navigating to the K: drive (see screenshot above) in hopes that it would be smart enough to reconnect the drive, but it didn't work.

Looking for suggestions and/or discrete workarounds, preferably powershell based, a one time configuration change, or something similar. If all else fails I might have to use net use and replace the current mapping, but that involves saving the credentials for the network drive in a script :-(

share|improve this question
    
I assume the user is on a domain because you're using GPO - that said, if you use a logon script you don't need to store credentials within the script –  DKNUCKLES Jan 24 at 15:35
1  
I solved this in the past by using a startup script that cd'ed to the directory after the network connected but before the user had gotten the program loaded up. I'm hoping someone else has a far more elegant solution... –  jlehtinen Jan 24 at 15:40
1  
Can this application use a UNC path instead? –  Mark Porter Jan 24 at 15:50
    
@DKNUCKLES this isn't a domain, I was going to use local gpo. I'll need to store creds since 1) it isn't a domain and 2) the login account is different on the machine storing the database. –  BigHomie Jan 24 at 15:59
2  
Check here mate: support.microsoft.com/kb/297684 –  TheCleaner Jan 24 at 19:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.