Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This is a cross post from superuser.com since no one over there seems to know anything.

I recently replaced a dying D-Link router (DI-524) with a Cisco/Linksys RSV4000. I'm really happy with the device but it seems when my cable modem is plugged in to it I lose 1/3 of my download speed. When I plug the modem right into my desktop I get 30mb/s down and 5mb/s up, but going through the router I get 20mb/s down.

I had a problem like this at work when we switched to Comcast as their boost service didn't work with the http proxy on our Watchguard firewall. So I tried turning off every option in the router to see if that had an effect but that didn’t change anything. I never had this problem with the old D-Link.

Someone said to check my MTU and change it to 1400 from 1500 but that didn't do anything on either the router or the desktops.

share|improve this question
    
haha Squillman you beat me to it –  Mark Henderson Aug 21 '09 at 2:59
    
By the way, I see in your SU post you mention calling Cisco or Linksys. I used to work for Cisco and the guys there hate nothing more than when people call Cisco for Linksys support. They're actually two different company, Cisco just dump their branding on it. Make sure you call the Linksys number :) –  Mark Henderson Aug 21 '09 at 3:01
    
@Farseeker: {grin} @Brian: kudos for going to SU first :) –  squillman Aug 21 '09 at 3:06
    
The funny thing about this firewall is there's nothing about it on the Linksys site. All the paperwork says to go to linksys.com etc. but info and firmware is posted on cisco.com under the small business group of items. Same goes for my WAP4410N which is a dual branded box from these guys. –  Brian Surowiec Aug 21 '09 at 4:34
add comment

2 Answers 2

up vote 4 down vote accepted

http://www.dslreports.com/forum/r18508174-RVS4000-Speed-problems-explained

Disabling IPS might work.

share|improve this answer
    
Aha! Underpowered processor can't handle IPS. Gotta love it. Turning off IPS shouldn't matter that much, because you have a good firewall on each computer... right? (Actually, I don't. I hate those interfering bastards. I like to live on the edge) –  Mark Henderson Aug 21 '09 at 3:16
    
Nice my speed is back...good thing this has gig wan, that should come in handy. I've been thinking of getting the new 101Mb/s service from Cablevision, guess I need to get a new new firewall first. –  Brian Surowiec Aug 21 '09 at 4:08
    
I am so jelous. In Australia the maximum connection you can get residentially is 30Mb cable from a company called Telstra, who are notorious for over-pricing and they charge you at 15c per Mb over your measly quota (max of 60gb). 99% of us have to settle for 1500Kb DSL, even on ADSL2 most people are too far away to get > 3mb. –  Mark Henderson Aug 21 '09 at 4:21
    
I was about to suggest an under-powered processor. The guys next door are working on routers and that is one of the problems that they face. –  sybreon Aug 21 '09 at 7:49
add comment

Changing MTU on a router connected to an ISP can cause more problems than it fixes, but 1500 is a pretty standard number.

Other issues can be QoS. If your router has built in QoS it may be deliberately throttling your HTTP connections, although if there's nothing else happening on the router then this should not be the case.

The other issue may be that 30Mbps is a fairly high link speed, so it may be possible that the Linksys's processor can't keep up with it. I've also seen routers that only have a 10mb router uplink port which screws you over when you sync at > 10Mb.

The 30Mb speed - where are you getting that from? Actual throughput (i.e. running a speed test in a browser), or looking at the sync speed in the router? If you're getting it through a speedtest site, check to see on the router if it's syncing at a similar speed, or if it claims to be syncing at 30Mb but you're only getting 20Mb.

share|improve this answer
    
When you are downloading are you getting 30 metabits, or bytes? –  mrdenny Aug 21 '09 at 3:10
    
I went on the assumption of bits. A 30 mega byte connection = 240Mbps... on cable... And there's no way in hell a Linksys router will keep up with that. –  Mark Henderson Aug 21 '09 at 3:17
    
The 30 megabits was from the speed test at speakeasy and the one from cablevision. I also get 3-3.5MB/s from Microsoft and Amazon S3 so I know the speeds are legit. –  Brian Surowiec Aug 21 '09 at 4:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.