Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to configure Linux Samba 4.0.9 for providing read-only access to directory content (symlinks to files from other locations) in user & password less way. Basically any LAN user should have access to content without any user/pass questions. I have following smb.conf:

[global]
    load printers = no
    guest account = guest
    name resolve order = lmhosts host wins bcast
    passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .
    socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=65536 SO_SNDBUF=65536
    preserve case = yes
    obey pam restrictions = yes
    encrypt passwords = true
    passwd program = /usr/bin/passwd %u
    dns proxy = no
    printing = bsd
    server string = Home Server
    invalid users =
    unix password sync = false
    workgroup = Home-Server
    log level = 2
    syslog only = yes
    os level = 20
    printcap name = /dev/null
    disable spoolss = yes
    syslog = 2
    security = user
    map to guest = Bad User
    panic action = /usr/share/samba/panic-action %d
    short preserve case = yes
    max log size = 1000
    unix extensions = no
    interfaces = lo lan0
    bind interfaces only = yes
    follow symlinks = yes
    wide symlinks = yes

[tv]
    comment = Myth Television
    available = yes
    browsable = yes
    public = yes
    writeable = no
    path = /myth/tv/pretty

[root]
    comment = Root FS
    path = /
    valid users = root
    force user = root
    force group = root
    admin users = root
    writeable = Yes

Above config gives me user/pass less access to [tv] - but attempt to access symlink gives me "Permission denied". Exactly the same symlink is working OK for [root] so I think issue is related to user/pass less access mode (where user/pass is bad and Samba is using 'map to guest = Bad User' directive). May somebody hint me about proper config? Thx in advance

share|improve this question

2 Answers 2

In order to allow symbolic links, you need to use wide links directive, instead of wide symlinks. I think that wide symlinks may be a typo, because I can't find a reference to it in the man page.

wide links = yes

Sources:

Edit: The version of SAMBA that my server is running is 3.6.3.

share|improve this answer

Well - it looks like I have old option name in smb.conf: instead of "wide symlinks = yes" there should be "wide links = yes". Now it works.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.