Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On my server I am trying to install a new usb drive but all that happens is the system starts using huge amounts of processor cycles with services.exe. On closer inspection with process explorer there is a thread with umpnpmgr.dll using most of the services.exe processor time.

I left it for a half hour and still nothing happened.

Rebooted and tried again, same result.

Tried a different usb drive, then a flash drive but still same issue.

Tried updating driver but it said the update function was already in action.

I have used process explorer to kill the thread now so the server can still perform its intended functions.

Any device that was previosly installed before this began happening will still work but any device new to the system will now work.

My question(s) is/are:

Is there a way to manually install the device into the registry so windows thinks it is a previously installed device?

Or can this problem be repaired through anything other than a reinstall? To do a reinstall would mena backing up large amount of data which is hard with a usb drive and insufficient space on any other network machine.

Any help would be greatly appreciated.


share|improve this question
It really looks like a hardware issue; can you provide some details on hardware on that machine? – Massimo Aug 24 '09 at 9:31
It is a HP Proliant ML150 Xeon 3Ghz, 2Gb, Win2k3 SBS… – Will3265 Aug 28 '09 at 5:10

The system file checker may be of assistance:

from cmd prompt... sfc /scannow

That should replace any damaged / modified system files.

Does the box participate in regular Windows updates? I know there have been a few uPNP updates for 03 that have solved similar issues.

share|improve this answer

You can take a look at this KB that microsoft released about that... it could help.

share|improve this answer
This one also: – r0ca Aug 26 '09 at 15:18
Its not all devices just new devices. Any device installed prior to the problem beginning still works – Will3265 Aug 28 '09 at 5:12
I think that it can be coming from an issue with the wmiprvse.exe process. I had it on my workstation like a year ago and I just renamed the registry to make sure the process won't load anymore. My lazy solution is not the best! Please take a look at this, it might help I guess! Hope you'll find what you' lookin' for! David. – r0ca Sep 1 '09 at 13:45

Just to explain 100% CPU usage... Kernel code uses spin locks instead of normal user-mode locking mechanisms. If something is waiting for your hardware to come alive, it will consume 100% CPU time on one of the cores.

I am guessing that either USB hub driver or the actual device driver code causes your pegged CPU -- at the end, it's likely waiting for something from hardware. It's also possible that two pieces in your system are deadlocked due to software, but I'd say that's least likely, as the USB code has been "in" since 2001, and is well-tested by now.

Please list your driver versions and manufacturers, as well as manufacturer id / device id so we can help you better.

share|improve this answer
I am unsure of which driver versions in particular to post. Every new device that I insert doesn't work or start and pushes the core usage to 100%. So far devices that haven't worked: - 1 Tb Lacie Drive > USB - 8 Gb Lexar Jumpdrive > USB - 500 Gb Seagate Drive > USB - Microsoft Mouse > USB - HP T1500 G3 UPS > Serial/COM I am at a lose on why everything is I plug in doesn't work – Will3265 Sep 11 '09 at 5:03
I was mostly interested in the chipset and usb hub drivers. – GregC Sep 13 '09 at 19:43

Hm, regarding your question of manually inserting registry keys into registry: you could try to install the same USB device on another PC (Win2003 server preferably) and do before and after registy snapshot. There are several free programs that can do it. Take a look at differences in registry and manually insert those in problematic machine.

And as a necessary disclamer: Of course you are going to do that on your own responsibility :)

share|improve this answer
Another thing that might help your issue - cause this thing I mention above is just a inelegant workaround (that may cause other problems). Have you tried to uninstall all USB devices and controllers via Device Manager? You know, My Computer [right click] -> Manage -> Device Manager -> USB Controllers...? You simply delete everything and then rescan for Hardware changes. (Of course it helps if your mouse and keyboard are connected via PS/2, or else at some point they will stop working :) ) – imagodei Sep 9 '09 at 18:51
It is a headless machine so I remote in. If I remove all the USB controllers I don't believe it will reinstall them. I tried to install a UPS via the COM/Serial port and that hung the machine also. I will try the registry trick on a couple of XP machines and see if that works. Thanks – Will3265 Sep 11 '09 at 5:45
It will reinstall everything, no worry. Drivers for specific HW won't get deleted, only actual USB ports/controllers. You can also make system restore point prior to deleting USB devices if you feel reserved about idea. – imagodei Sep 11 '09 at 6:24
thanks I will try this out – Will3265 Nov 26 '09 at 23:57

I've run into this with large Western Digital (or WD drives repackaged under a different brand name) drives being plugged into Windows 2000 servers before, but never 2003. As a work around, I would open up the services control panel and stop the logical disk manager service, then plug the drive in, and then start the LDM service.

This would usually get it to pick up the drive within 10-15 seconds rather than the 60-120 seconds it would take by just plugging it in.

Never did find a fix--but I only ran into this well after people should have moved away from Win2k. After they moved to Windows 2003 I never ran into it again.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.