Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an HP Proliant SL250s Gen8 (right-hand) server which is apparently not able to boot from the network. If I configure the system to PXE boot in the BIOS, or if I hit F12, it does start up the Intel boot agent (for netboot) and claims to be attempting to DHCP. However, the system does not boot. In addition, running tcpdump -i eth0 -s 1500 port bootps or port bootpc on the PXE server during boot does not show any DHCP requests from the server MAC address.

I have confirmed that a second server, using the same switch port and cable, is capable of booting using my PXE server. When booting the second server, the above tcpdump command successfully captures the DHCP request.

I haven't worked with HP servers much before. Is there a "make it boot" button in the BIOS somewhere that I've missed? ;-)

share|improve this question

Hitting the F12 key when prompted is the proper way to force a network boot on ProLiant servers.

Is this a completely new installation, or are you repurposing an older server? There are some BIOS switches that could alter the server's behavior from what you'd expect. Clearing the BIOS and NVRAM and resetting the system to default may be a reasonable option.

But first, please make sure you're using the correct NIC port on the front of the server node. You should be using the port denoted #9 in the image below.

enter image description here

share|improve this answer

The port speed setting in the system boot agent for PXE booting may not be set to AutoNeg with the switch port configuration (e.g. nic port speed in boot agent set to 100 / F while the switch is configured for 1000 / F). Mismatch speed, as you know, is the bane for network connectivity. To check:

  1. hit CTRL+S during system POST
    *this system rom access may or may not be prompted on your system during POST
    *if CTRL+S does not work, check the system guide for specifics in how to to access the Boot Agent for your particular system
  2. select the port to configure or check
  3. change port speed setting to AutoNeg, if not already set that way or force it to operate at a certain speed as needed
  4. make sure all the other setting make sense and match any specific configuration requirement. Change only as needed.
  5. confirm exit and save setting for each port
  6. exit and continue with system POST or boot process
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.