Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have installed vsftpd with apt-get install vsftpd on my freshly deployed ubuntu saucy amd64 linode.

vsftpd starts but when I connect to it from an ftp client, even from localhost, I get this error: OOPS: child died

syslog and kern.log show this:

Jan 28 14:00:37 gravy kernel: type=1326 audit(1390917637.827:67): auid=4294967295 uid=65534 gid=65534 ses=4294967295 pid=27687 comm="vsftpd" sig=31 syscall=96 compat=0 ip=0x7fff48196968 code=0x0

The default configuration options in /etc/vsftpd.conf are:

listen=YES
anonymous_enable=NO
local_enable=YES
dirmessage_enable=YES
use_localtime=YES
xferlog_enable=YES
connect_from_port_20=YES
secure_chroot_dir=/var/run/vsftpd/empty
pam_service_name=vsftpd
rsa_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
rsa_private_key_file=/etc/ssl/private/ssl-cert-snakeoil.key

I though it might be something to do with pam or SSL so I commented out those last 3 lines and restarted but still get the same problem.

There is nothing in /var/log/vsftpd.log

share|improve this question

1 Answer 1

up vote 0 down vote accepted

There was a bug in vsftpd that affected 64-bit machines, here's the bug report - it looks fixed on Red Hat's distributions but it's not yet fixed on some other distributions.

As a workaround, you may add seccomp_sandbox=NO to its configuration file but that will disable a sandboxing feature (not sure about what it does exactly, but if security is your priority you shouldn't use FTP anyway).

echo "seccomp_sandbox=NO" >> /etc/vsftpd.conf
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.