Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

In my office, I have a printer with static IP 192.168.0.254/24. Normally, it should be excluded from the DHCP pool in the router. So I just set the DHCP pool to be in the range of 192.168.0.2/24 - 192.168.0.240/24, 192.168.0.241/24 - 192.168.0.254/24 will be left for some machines that require static IP like the printer.

Then I also added the static IP 192.168.0.254/24 in the router for the printer. It seems there's nothing wrong. But with these settings, the printer is inaccessible to other machines in the same network. That is, nobody is able to print from their computer and it doesn't respond to any PING request like before.

I had completely no idea. So I just tried some luck by configuring the DHCP range to cover as most IPs as it can, which is 192.168.0.2/24 - 192.168.0.254/24.

After router restart, the printer is now completely accessible and can respond to PING just like it was before we replaced the old router with this one (Cisco RV180W).

So my question is, shouldn't we exclude a static IP from the DHCP pool?

I have included some screenshots below that show our current configuration:

enter image description here enter image description here enter image description here

Note: you can see there are some machines using static IPs but I still haven't added them in the Static DHCP Client Table because I plan to change them to use dynamic IP later.

share|improve this question
1  
I would find the printer configuration more interesting. –  Michael Hampton Jan 29 at 5:30
    
@Michael Hampton♦ From the front panel of the printer, it shows 192.168.0.254 as its IP. Since I don't have admin access to the printer, this is the only info I can get. –  bobo Jan 29 at 5:58
2  
My guess, then, would be that the printer is actually getting its IP address via DHCP, and it only "works" because there's a DHCP reservation for it. –  Michael Hampton Jan 29 at 6:01
    
@Michael Hampton♦ I didn't have the concept of DHCP reservation so I didn't ever consider this possibility. I think your guess is most likely a correct one. I will see if I can get the admin access and confirm on this and report back. –  bobo Jan 29 at 6:52

1 Answer 1

up vote 3 down vote accepted

I'm going to preface this answer (that I already typed out, and am thus, not going to delete) by saying that it looks like your router uses the term "static DHCP" for what the rest of the world calls a "DHCP reservation."

So, in fact, the proper configuration of your device is to have your DHCP pool set from 192.168.0.2 to 192.168.0.254, and then to put all those static addresses I see in the LAN hosts table into the "Static DHCP" client table. (If you don't put them in the Static DHCP table, the DHCP server may assign those IP addresses to another device, creating an IP conflict.)

Also...

  1. I have almost no experience using Cisco Small Business gear, so I'm not 100% sure of the above, but that's sure what it looks like.
  2. Your use of the subnet designation (/24) is not correct, and confusing.
    • If you're punching that into your config, it's going to cause problems. If you're just typing it that way, that's better... but still wrong and confusing.
    • 192.168.0.241/24 is not a valid subnet. It's 192.168.0.0/24. The /24 indicates that it is a 24 bit subnet composed of 256 IP addresses.

Anyway, moving onto the general case...


Shouldn't we exclude a static IP from the DHCP pool?

In short, yes. You should exclude any statically-assigned IP addresses from being assigned from your DHCP pool. If you don't, your DHCP server will happily assign that static IP address to a device requesting a DHCP-assigned address, and you'll end up with an IP conflict, and some potentially confusing connection issues reported by your users.

As to how you typically accomplish this, there are basically three ways.

  1. Actually exclude the IP address from the DHCP pool range.
    • This will make the DHCP server ignore that IP address, as if it doesn't exist.

  2. Create a DHCP "reservation."
    • This will force the DHCP server to always assign that "reserved" IP address to the device you specify (or any device with the same MAC address, to be precise).
    • It looks like your router calls that option a "static DHCP." (Since DHCP stands for "Dynamic Host Configuration Protocol," this is a dumb name.)

  3. Use hostnames and DNS instead.
    • Instead of messing around with IP addresses that the majority of devices don't care about and users won't remember, assign a hostname, use a nameserver and access your devices by hostname instead of IP, so you can let everything get a dynamic address from your DHCP server and not care what the actual IP address is.
share|improve this answer
    
I didn't know about DHCP reservation so didn't think about this possibility, which is probably the reason why the printer behaves like this. Regarding /24, I just want to indicate the subnet mask of the IP, I didn't pay much attention about its correct usage but I now know about it. Thanks so much for your detailed explanations. –  bobo Jan 29 at 7:24
    
By the way, if anybody wants to get into the admin interface of this router to play around with it. Here you can find the online demos, hope you like it: supportforums.cisco.com/community/netpro/small-business/… –  bobo Jan 29 at 7:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.