Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have an annoying issue.

I Have made a ASP.NET application that opens winword.exe using the Administrator account since that is the only account I can get to function correctly.

The only issue is when I am not logged in as an administrator it won't work.

How do I make it work everytime?

I have tried to grant access to NETWORK SERVICE and letting it open WINWORD.exe. But it just opens winword and then nothing else happens.

I think the issue might be that winword is beeing run for the first time and some popups blocks the way. So alternatively, is there anyway I can login as NETWORK SERVICE and run winword??

Thanks in advance guys

share|improve this question
    
How exactly do you expect to run Winword.exe without any desktop session available?!? What are you using it for? –  Massimo Aug 21 '09 at 10:37
    
Hello My Application autogenerates 4 word documents from 4 word templates. Saves them, zip them and the user can then download this zip file. I am using a COM assembly made by microsoft called Microsoft.Office.Interop.Word.dll The security configuration can be found under "Component Services" - "Computers" - "My Computer" - "DCOM Config" - "Microsoft Office Word". In here I have granted all the apropriate permissions for NETOWRK SERVICE. Under Services I have allowed the IIS Admin til interact with the desktop. –  user16966 Aug 21 '09 at 11:26

2 Answers 2

Instead of opening Word interactively you should be using the Office components and creating Word application objects to handle the work. This will let you avoid any interactive dialogs that Word would prompt you with.

share|improve this answer
    
This is exactly what I am doing and you have no idea how long that is away from working when you leave the debug environment and deploy it on the server. You have to setup a MASSIVE amount of Dynamic COM settings. Change all rights in your Web App. Make sure the executing account can open desktop. Set Identity imitation in web.config and so on for ages. –  user16966 Aug 21 '09 at 12:33
    
Sorry, blew out those garbage links. Was thinking of something else. Should should not, though, need to run winword.exe to get this accomplished. –  squillman Aug 21 '09 at 13:06

Okay I got it working

It takes the following steps:

  1. Click START-->RUN and enter "dcomcnfg"
  2. In the "Applications" tab, go down to "Microsoft Word Document"
  3. Click PROPERTIES button
  4. Go to the "Security" Tab
  5. Click "Use custom access permissions", and then click EDIT
  6. Click ADD and then click SHOW USERS
  7. Highlight the IIS anonymous user account (usually IUSR_ , click ADD
  8. Go back to the "Security" tab by hitting OK
  9. Click "Use custom launch permissions", and the click EDIT
  10. Click ADD and then click SHOW USERS
  11. Highlight the IIS anonymous user account (usually IUSR_ , click ADD
  12. Hit OK, and then hit APPLY.

After that hit the Identity tab. In here you choose a user that has administrator rights and typ username and password.

You go into Services -> IIS Admin -> Allow it to work with the desktop.

Thank God I am done with this issue. Btw I do not in any way say that this is a secure way to do this. I however don't have any issues doing it since my server is internal.

share|improve this answer
    
Just curious- "...since that is the only account I can get to function correctly." - does this mean that there are other issues with the machine that need to be addressed? Also, thanks for posting the steps. Very intersting to me. –  cop1152 Aug 21 '09 at 12:46
    
I am still very new to it and some of the things I have done seems to be closer to luck than anything else. There might be more steps needed, but as I see it you have to use a user with administrator rights and you can't use a build in NT AUTHORITY user. –  user16966 Aug 21 '09 at 13:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.