Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I installed PHP 5.5 on my Amazon Linux VPS via the instructions here. The CLI is working fine.

I also had apache already installed and running via the httpd package. It was running without any issue.

I see that there is no mod_php in the list of available modules. Now when I try to restart httpd I get the error:

httpd: Syntax error on line 222 of /etc/httpd/conf/httpd.conf: Syntax error on line 6 of /etc/httpd/conf.d/php.conf: Cannot load /etc/httpd/modules/libphp5.so into server: /etc/httpd/modules/libphp5.so: symbol SSLeay_version, version OPENSSL_1.0.1 not defined in file libcrypto.so.10 with link time reference

I've looked up parts of this error, and the general advice seems to be to run

yum update openssl

However, when I run this I just get:

No packages marked for update

When I run install instead of update, I get:

Package 1:openssl-1.0.1e-4.55.amzn1.x86_64 already installed and latest version
Nothing to do

I'm not sure what else to do at this point.

share|improve this question
    
It's definitely a version mismatch. You could always compile PHP yourself to avoid it. –  Nathan C Jan 29 at 18:31

1 Answer 1

up vote 1 down vote accepted

The php55 package in Amazon's repositories depends on httpd24, not httpd (which is 2.2). Using the more recent version of Apache should resolve your issues.

$ repoquery --requires php55
/bin/sh
httpd-mmn = 20120211-x86-64
httpd24
...
share|improve this answer
    
Perfect; this is just what I needed. As a followup question how can I get php working with apache now? yum install mod_php says there are some conflicts; I'm not sure if there is a way around that –  Explosion Pills Jan 29 at 18:46
1  
You really shouldn't use CentOS/RedHat instructions for Amazon Linux. They're similar, but not the same. php55 is the package you want. yum install php55 installs both PHP 5.5 and Apache 2.4 and includes mod_php as part of that process. Stock Amazon Linux has no package named mod_php - if you see one in yum search you've got extra repos enabled. –  ceejayoz Jan 29 at 19:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.