Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently switched my site over to using HTTPS in all the URL's. (My post here)

I am running Apache with PHP on Ubuntu 12.0.4

I was told that I should install the Apache module for SPDY since I am using SSL / HTTPS so I followed the directions on this site to install it, it installed without a problem... https://developers.google.com/speed/spdy/mod_spdy/

My problems start with PHP... if you view this page https://developers.google.com/speed/spdy/mod_spdy/php you can read about using PHP with SPDY

Basically it says that you need to use mod_fcgid instead of mod_php

My server currently uses mod_php for all my sites to run. So I installed the mod_fcgid handler and it installed without an issue. The problem was when I try to re-boot Apache. Things went crazy due to the content in my Apach config files.

from my http.conf file...

<IfModule mod_php5.c>
    AddType application/x-httpd-php .php
    php_flag magic_quotes_gpc Off
    php_flag track_vars On
    php_flag register_globals Off
    php_admin_value upload_tmp_dir /var/zpanel/temp
</IfModule>

Changing the mod_php5 above to use the new mod_fcgid does not resolve my issues, it instead says that there is a problem with things like php_flag magic_quotes_gpc Off it appears php_flag is not valid when using mod_fcgid ?

Sorry I don't have the exact errors now as I have restored my server back to mod_php so that it will work.

Everywhere in my config files where I have calls to mod_fcgid seemed to through an error though.

Any ideas how I can get this working?

share|improve this question
    
Use a test server with a copy of your existing configuration to experiment. –  Michael Hampton Feb 1 at 19:23

1 Answer 1

When you're using mod_fcgid apache doesn't know anything about php anymore. It simply sends it off. So those configurations can't be in any apache configs. You'll need to add those settings to php.ini.

http://httpd.apache.org/mod_fcgid/mod/mod_fcgid.html

http://www.howtoforge.com/how-to-set-up-apache2-with-mod_fcgid-and-php5-on-centos-6.2

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.