Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

For quiet sometime I've been dealing with a random switch from HTTP to HTTPS, at times it vanishes after a few attempts to remove the https from the url, otherwise I have to clear my cache to be allowed to access the site again, since a header appears to set a 301 moved permanently.

When the site opens with the HTTPS I get the "Certificate is not Secure" thing, and asked wether I wanna continue or not, if I continue I get thrown to a my VMware ESXI SSL information page, (My server is a Virtual machine). Though after a little time it "vanishes" and i have to clear cache before I'm allowed to proceed to the original site with HTTP.

Here's a image of the page I get when I press continue at the Certificate warning! http://s12.postimg.org/75zerd2d9/cert_issue.png

There is NO SSL installed on the server and I have out commentet anyline in the Apache dealing with the SSL.

The Apache logs gives me nothing apart from this:

xx.xxx.xxx.xxx - - [31/Jan/2014:09:57:52 +0100] "-" 408 0 "-" "-"

and this is the start of my site.com in /etc/apache2/sites-enabled:

Listen 80
<VirtualHost *:80>

while I have outcommentet all ports in the ports.conf

I have 3 VM servers on my host (All with Ubuntu 12.04) and only 1 is configured with SSL but all 3 have their independent IP's. Though the network is configured with each their IP address, but otherwise the same netmask and same gateway / pointopoint

The code below are for each server. (meaning that this bit exists on each server).

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
# Main IP address of the server
address x.x.xxx.xxx
# Netmask 255.255.255.255 (/32) independent from the
# real subnet size (e.g. /27)
netmask xxx.xxx.xxx.xxx
# explicit host route to the gateway
gateway x.x.xx.xx 
pointopoint x.x.xx.xx

I don't know what to do anymore since everything I've tried doesn't seem to fix the issue.

share|improve this question
    
Are you saying you have three single Ubuntu containers (each with their own IP), or you have an Ubuntu container with three IP's defined? If it's the former your VirtualHost config above should be <VirtualHost $IP:80> instead (otherwise Apache will listen on all and respond from any). When you connect are you connecting to the eth0 IP of your VM, or to the main IP of your server? –  Rudu Jan 31 at 19:21
    
three single virtual Ubuntu containers, setup on a single physical server. i connect via a domain name that points to the ubuntu container's ip –  Rasmus Boie Jan 31 at 23:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.