Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I know many people claim to get this error and that this could be caused by the RPC services or some other registry port limits, however I have spend hours trying to resolve an issue that all started when one computer crashed due to a bad system board. Since we did not have any spare system boards, I resorted to moving the hardrive into another simular computer, same hardware model etc. I then tried to login to this PC and it would only let me login locally. Perthaps this was becuase the network card mac address changed. So here I decided to unjoin the domain and delete this computers name in AD example "computer1" I proceeded to delete in DNS. Next I to rejoin "computer1" to my same Domain and after about 45 seconds I got the famous endpoint mapper error.

Message states: Computer name changes: the following error has occured: there are no more endpoints available from the endpoint mapper" Yet I cannot find any specific event logs on either the client PC and or the Domain Controller. I am not able to re-join this computer to my domain with the same computer name "computer1" so this computer remains in a workgroup, yet in active directory the name "computer1" was created again. i find this really strange.

if I try to join the domain with another name like 'computer2' I get the message welcome to my domain, however I get a few clicks latter saying that computer could not be renamed. Yet in active directory in still creates the "computer1" name and not the new name. Also after rebooting the pc the name computer1 is still present as the local computer name, yet it appears to be joined to the domain as I get the domain dropdown option at login.

Finally I cannot login to "computer1" using any valid domain admin accounts. I get an error: windows cannot contact the Domain Controller, either because......"

I've tried so many things including sysprep the pc, reseting winsock, changing the name while in workgroup first and rebooting first and even then I cannot join the domain, I keep getting the endpoint mapper errors.

What else can be wrong. This hardrive was previously on the domain and working fine. Why won't it let me join it again.

share|improve this question

2 Answers 2

you should remove the computer from active directory users and computer and try to rejoin it.if this doesnt work try sysprep open run and type %systemroot%\System32\Sysprep\sysprep.exe then select enter system out-of-box experience (OOBE)and check generalize. after rebooting try to rejoin it to your domain.

check this out for more information

share|improve this answer
    
Thanks, but I mentioned that I had already tried sysprep and winsock resets. I re-entered the Ip address, gateway and dns entries each time. This did not work. –  David Perry Feb 3 at 13:51
    
i had this problem but solved with sysprep with checking generalize checkbox,you can try another way,remove the user directory in local machine,and restart pc then try to rejoin it. –  Hamed Shahinnejad Feb 5 at 6:47
    
This is really a comment, not an answer. –  Tom O'Connor Feb 5 at 7:49

It's most likely something in network layer

verify that there is not port exhaustion issue

turn off all firewall, antivirus, host intrusion prevention service, etc.

upgrade NIC driver

on client, run portqryUI, select the pre-defined rule set for "domain & trust", select a DC as your target, all major ports should be listed as listening. There are a few non-critical ports can be "not listening".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.