Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install ubuntu 12.04 via preceed config onto Dell PowerEdge R710. I had RedHat installed on the box then I tried installing ubuntu 12.04, then auto install popping with Unable to automatically remove LVM data message.

Complete Message: Because the volume groups on the selected device also consist of physical volumes on other devices. it is not considered safe to remove its lvm data automatically. If you wish to use this device for paritioning, please remove its lvm data first.

couple of blogs suggested to use this preceed option

d-i partman-lvm/device_remove_lvm_span boolean true

But no use, I still get the same message.

Also one more question: Ubuntu preceed auto install on dell servers showing first disk as /dev/sdc not /dev/sda. Any idea.

Appreciate for your answer.

share|improve this question
add comment

1 Answer

Assuming you have nothing on the drive that you need to save, try dd if=/dev/zero of=/dev/sdc bs=512 count=1. That should wipe the MBR and partition table. Don't do this if you have data on the drive that you need.

As for it showing up as /dev/sdc instead of /dev/sda, you should be able to see what was assigned sda and sdb by running dmesg. My money is on your R710 having a built in SD card slot which is being assigned as sda. You can disable it in the bios settings.

share|improve this answer
    
Will give a try. I really don't care about the data. All I want is to install ubuntu onto the first disk. So there is no option from preceed to do this other than running the dd command. Thanks for the quick reply –  JackBos Jan 31 at 19:54
    
As you said /dev/sda and /dev/sdb were assigned to usb devices. Tried after disabling usb's from bios settings, but still they usb ports were discovered. Probably I am missing some setting on iDRAC, will check. dd command specified under preseed early_command, but still no use, will figure out. Thanks.. –  JackBos Feb 1 at 3:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.