Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

3 times in the last week I've arrived in the office to find our email not working. When I log on to the Exchange 2003 server, there is a yellow warning icon in the system tray notifying me of low virtual memory. I restart the server and everything is OK. In trying to find out why this is happening, I've discovered that the Mail store is 82GB (well above the 75GB limit of Exchange Standard). Apart from asking users to manage their mailboxes, what else can I do to reduce the size of the mail store?

I need this server to continue functioning for a few more months while we discuss Hosted vs On-premise Exchange 2013.

It is a Windows Server 2003 Standard running Exchange 2003 Standard. We have all latest updates installed, 4GB RAM. I have 3-6GB virtual memory set. And I'm using the /3GB and /userva switches in the boot.ini. There is a few more than 60 users in total. I have deleted items retention for 1 week. Logging on for track & trace, and a 2GB mailbox size limit.

Thanks in advance

Store size warnings in event viewer

share|improve this question
    
This problem doesn't appear to be related to the size of the mailbox database, the size of the mailboxes or the number of mailboxes. It appears to be related to virtual memory. What do you have /userva set to? Have you considred configuring a static pagefile or letting Windows manage the pagefile? –  joeqwerty Feb 2 at 23:29
    
/userva set to 3030. Pagefile was set at 2-4GB. I adjusted it to 3-6GB this morning. Could it be related to a Store dismount due to the mail store size limit if the nightly backup procedure(s) are looking for an online store to do the backup? I'm getting a lot of these warnings in the event viewer: imgur.com/a48DdE8 –  Reece Dodds Feb 2 at 23:37
    
I wouldn't think the event log entries or the Store dismounts are related to the virtual memory warning. Try setting the pagefile to system managed instead of manually setting it. In addition, by setting the Min and Max pagefile to different values you're creating a fragmented pagefile, which will only add to any performance problems you may be having. –  joeqwerty Feb 2 at 23:43

1 Answer 1

So you've identified 2 problems here that may or may not be contributing to your Exchange interruptions, however they're probably not actually related to each other.

Firstly, your pagefile is quite small. As a general rule, it needs to be at least as much as the physical RAM you have available, but typically likes to be a little more than that. So I would start by increasing your pagefile to at least 4gb, and preferably make the minimum and maximum values the same, so it doesn't grow. So maybe a static 5gb.

Secondly, as your event viewer is reporting, your exchange store is quite large, I would get to work on archiving old emails, (even if it's just to PST files).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.