Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have centos 6.4 64 bit and I accidently uninstalled my php-mysql extension, as a result my wordpress site is down.

I need to install php-mysql (note, I prefer to get mysqlnd, but first I just need to get mysql installed again)

I run yum install php-mysqlnd and I get the following errors:

Error: Package: php-5.4.24-1.el6.remi.x86_64 (remi)
       Requires: libcrypto.so.10(libcrypto.so.10)(64bit)
Error: Package: php-cli-5.4.24-1.el6.remi.x86_64 (remi)
       Requires: libcrypto.so.10(libcrypto.so.10)(64bit)
Error: Package: php-cli-5.4.24-1.el6.remi.x86_64 (remi)
       Requires: libssl.so.10(libssl.so.10)(64bit)
Error: Package: php-5.4.24-1.el6.remi.x86_64 (remi)
       Requires: libcrypto.so.10(OPENSSL_1.0.1)(64bit)
Error: Package: php-cli-5.4.24-1.el6.remi.x86_64 (remi)
       Requires: libcrypto.so.10(OPENSSL_1.0.1)(64bit)
Error: Package: php-5.4.24-1.el6.remi.x86_64 (remi)
       Requires: libssl.so.10(libssl.so.10)(64bit)

I have done some research and it seems it has to do with centos 6.4 shipping with the ssl 1.0 instead of 1.0.1 which is a dependency for mysqlnd. So I tried to install the above libraries and it worked, but the errors keep appearing so I can't install mysqlnd so I can't use my website.

Any suggestions?

share|improve this question

marked as duplicate by Michael Hampton Feb 3 at 17:08

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

It's because you need to update to centos 6.5. SSL 1.0.1 will be available there.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.