Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

OS: CentOS 6.4 64 bit Mail server: Postfix + Dovecot + MySQL + postfixadmin + Clam + Amavis

I have installed a postfixmail server with dovecot,postfixadmin and mysql(virtual domains). I can send and recieve mails using roundcube webmail. However I am unable to send mail from any mail clients. But I can check my inbox and read mails using mail clients. I have added my IP to "mynetworks", still not working.

Telnet to port 25 or 465 is not working. I have turned off firewall for testing.

Here is my postconf -n output, I have replaced my original domain name with "mysite.com"

[root@mail postfix]# postconf -n   
alias_database = hash:/etc/aliases  
alias_maps = hash:/etc/aliases   
broken_sasl_auth_clients = yes  
command_directory = /usr/sbin  
config_directory = /etc/postfix  
daemon_directory = /usr/libexec/postfix  
data_directory = /var/lib/postfix  
debug_peer_level = 2  
delay_warning_time = 4  
disable_vrfy_command = yes   
html_directory = no   
inet_interfaces = all  
inet_protocols = all  
mail_owner = postfix  
mailbox_size_limit = 5120000000  
mailq_path = /usr/bin/mailq.postfix  
manpage_directory = /usr/share/man  
message_size_limit = 204800000  
mydestination = $myhostname, localhost.$mydomain, localhost  
mydomain = mysite.com  
myhostname = mail.mysite.com  
mynetworks = $config_directory/mynetworks  
newaliases_path = /usr/bin/newaliases.postfix  
queue_directory = /var/spool/postfix  
readme_directory = /usr/share/doc/postfix-2.6.6/README_FILES  
recipient_delimiter = +  
relay_domains = proxy:mysql:/etc/postfix/mysql-relay_domains_maps.cf  
sample_directory = /usr/share/doc/postfix-2.6.6/samples  
sendmail_path = /usr/sbin/sendmail.postfix  
setgid_group = postdrop  
smtp_tls_session_cache_database = btree:$data_directory/smtp_tls_session_cache  
smtp_use_tls = yes  
smtpd_client_restrictions =   
smtpd_data_restrictions = reject_unauth_pipelining  
smtpd_helo_required = yes  
smtpd_helo_restrictions =   
smtpd_recipient_restrictions = permit_sasl_authenticated,         permit_mynetworks,         reject_unauth_destination, reject_non_fqdn_sender,        reject_non_fqdn_recipient,         reject_unknown_recipient_domain  
smtpd_sasl_auth_enable = yes  
smtpd_sasl_local_domain = $myhostname  
smtpd_sasl_path = private/auth  
smtpd_sasl_security_options = noanonymous  
smtpd_sasl_type = dovecot  
smtpd_sender_restrictions =   
smtpd_tls_CAfile = /etc/pki/tls/certs/cacert.pem  
smtpd_tls_cert_file = /etc/pki/tls/certs/mail.mysite.com.crt 
smtpd_tls_key_file = /etc/pki/tls/private/mail.mysite.com.key 
smtpd_tls_loglevel = 1 
smtpd_tls_received_header = yes 
smtpd_tls_security_level = may 
smtpd_tls_session_cache_timeout = 3600s 
smtpd_use_tls = yes 
tls_random_source = dev:/dev/urandom 
transport_maps = hash:/etc/postfix/transport 
unknown_local_recipient_reject_code = 550 
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_alias_maps.cf,regexp:/etc/postfix/virtual_regexp 
virtual_gid_maps = static:12 
virtual_mailbox_base = /home/vmail 
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains_maps.cf 
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_maps.cf 
virtual_minimum_uid = 101 
virtual_transport = dovecot 
virtual_uid_maps = static:101 

Here is master.cf

[root@mail postfix]# cat master.cf
#
# Postfix master process configuration file.  For details on the format
# of the file, see the Postfix master(5) manual page.
#
# ***** Unused items removed *****
# ==========================================================================
# service type  private unpriv  chroot  wakeup  maxproc command + args
#               (yes)   (yes)   (yes)   (never) (100)
# ==========================================================================
smtps inet n - n - - smtpd
 -o smtpd_tls_wrappermode=yes
smtp      inet  n       -       n       -       -       smtpd
  -o content_filter=smtp-amavis:127.0.0.1:10024
  -o receive_override_options=no_address_mappings
pickup    fifo  n       -       n       60      1       pickup
  -o content_filter= 
  -o receive_override_options=no_header_body_checks
cleanup   unix  n       -       n       -       0       cleanup
qmgr      fifo  n       -       n       300     1       qmgr
#qmgr     fifo  n       -       n       300     1       oqmgr
tlsmgr    unix  -       -       n       1000?   1       tlsmgr
rewrite   unix  -       -       n       -       -       trivial-rewrite
bounce    unix  -       -       n       -       0       bounce
defer     unix  -       -       n       -       0       bounce
trace     unix  -       -       n       -       0       bounce
verify    unix  -       -       n       -       1       verify
flush     unix  n       -       n       1000?   0       flush
proxymap  unix  -       -       n       -       -       proxymap
smtp      unix  -       -       n       -       -       smtp
# When relaying mail as backup MX, disable fallback_relay to avoid MX loops
relay     unix  -       -       n       -       -       smtp
        -o fallback_relay=
#       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq     unix  n       -       n       -       -       showq
error     unix  -       -       n       -       -       error
discard   unix  -       -       n       -       -       discard
local     unix  -       n       n       -       -       local
virtual   unix  -       n       n       -       -       virtual
lmtp      unix  -       -       n       -       -       lmtp
anvil     unix  -       -       n       -       1       anvil
scache    unix  -       -       n       -       1       scache
#
# ====================================================================
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
# ====================================================================
maildrop  unix  -       n       n       -       -       pipe
  flags=DRhu user=vmail argv=/usr/local/bin/maildrop -d ${recipient}
uucp      unix  -       n       n       -       -       pipe
  flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
ifmail    unix  -       n       n       -       -       pipe
  flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp     unix  -       n       n       -       -       pipe
  flags=Fq. user=foo argv=/usr/local/sbin/bsmtp -f $sender $nexthop $recipient
#
# spam/virus section
#
smtp-amavis  unix  -    -       y       -       2       smtp
  -o smtp_data_done_timeout=1200
  -o disable_dns_lookups=yes
  -o smtp_send_xforward_command=yes
127.0.0.1:10025 inet n  -       y       -       -       smtpd
  -o content_filter=
  -o smtpd_helo_restrictions=
  -o smtpd_sender_restrictions=
  -o smtpd_recipient_restrictions=permit_mynetworks,reject
  -o mynetworks=127.0.0.0/8
  -o smtpd_error_sleep_time=0
  -o smtpd_soft_error_limit=1001
  -o smtpd_hard_error_limit=1000
  -o receive_override_options=no_header_body_checks
  -o smtpd_bind_address=127.0.0.1
  -o smtpd_helo_required=no
  -o smtpd_client_restrictions=
  -o smtpd_restriction_classes=
  -o disable_vrfy_command=no
  -o strict_rfc821_envelopes=yes
#
# Dovecot LDA
dovecot   unix  -       n       n       -       -       pipe
  flags=DRhu user=vmail:mail argv=/usr/libexec/dovecot/deliver -d ${recipient}
#
# Vacation mail
vacation    unix  -       n       n       -       -       pipe
  flags=Rq user=vacation argv=/var/spool/vacation/vacation.pl -f ${sender} -- ${recipient}

Can anyone please direct me here. I am lost and not sure what is the problem.

I followed this articles with some modifications. https://mail.google.com/mail/u/1/?shva=1#search/postfix/13ed169e1ae643b6

Thanks

share|improve this question
    
Can you add ` -o smtpd_sasl_auth_enable=yes -o smtpd_client_restrictions=permit_sasl_authenticated,reject` to your smtps line in master.cf? Also, if you run netstat -pan | grep 465 do you see anything? –  NickW Feb 4 at 9:25
    
The postfix is already listening on port 465 –  Abdul Feb 4 at 12:54
    
Did you add those two lines to master.cf and restart postfix? –  NickW Feb 4 at 12:56
    
Plus, what does your log say? –  NickW Feb 4 at 12:58
    
The submission section is missing from your master.cf. Remember that outgoing mail uses submission on port 587. –  Michael Hampton Feb 4 at 13:24
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.