Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am doing development remotely over RDP and all of a sudden I have a very strange issue: whenever I launch Visual Studio (2010), the remote machine loses all network connectivity for about 15 minutes (at which time it comes back). I am not sure exactly when it started, but it was fine a few weeks ago.

Really hard to debug remotely and there is nothing in the event logs.

Has anyone seen this issue before? Suggestions?

share|improve this question

closed as off-topic by Iain, Katherine Villyard, mdpc, Ward, EEAA Feb 12 '14 at 5:08

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is dedicated to professional system and network administrators. End user and enthusiast questions are off-topic (contact your system administrator or hire a professional to help you out). Please see the Help Center for more information." – mdpc, Ward, EEAA
If this question can be reworded to fit the rules in the help center, please edit the question.

    
No. Reinstall. Never seen that and VS should not trigger that. –  TomTom Feb 4 '14 at 20:31
    
That would be a very last resort - trying to avoid that for obvious reasons... –  user208115 Feb 4 '14 at 20:34
    
WOuld be my first step. Unless you run a debugger, VS is a complete user level appliation. If that results in RDP issues there is a fundamental problem. Check your drivers. –  TomTom Feb 4 '14 at 21:07
    
This is solved; it was somehow caused by Resharper (8.1.23.546). I could start VS fine in SafeMode and the moment I uninstalled Resharper, the problem went away. I then tried to reinstall it, and the problem came back. I am not sure how Resharper could cause this, but it did (or at least it triggered whatever the root problem was). Lastly, some more details on the problem: when starting VS, the network icon in the tray bar would show "No Internet access" and you could no longer reach anything over the network. After 10 minutes the network access would come back. –  user208115 Feb 5 '14 at 1:33
    
What the heck? Resharper is also a user level program and I totally fail to see how that should trigge that. Damn. –  TomTom Feb 5 '14 at 6:22

1 Answer 1

Here is some more data, in case it helps somebody. I did a fresh install of a VM with Windows Server 2008 R2, but the same issue!

I contacted JetBrains support, and they requested that I start Visual Studio with these switches: "devenv /ReSharper.LogFile C:\resharper_log.txt /ReSharper.LogLevel Verbose"

to collect Resharper log data. When I did, the machine lost network (as always), and it took several hours to come back. The log file was 3.7 GB(!) with millions of this line: Thread:25: [ULCCC] Received from=x.x.x.x:63300, windowUserName=joe userName=Joe Doe

So it appears to basically DOS itself somehow.

I heard back from JetBrains and they asked me to try to change the license to Eval (instead of registered), and it handled the issue. I am waiting to hear back on a more permanent solution. So it is basically a flaw in their license check mechanism.

share|improve this answer
    
Time to start laughing. THis is the first time I hear of a software ddos'ing the server it is installed on. OUCH. A SERIOUS issue in their licensing. THey better fix that one - fast. Grats for finding it. –  TomTom Feb 11 '14 at 14:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.