Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install the imagick pecl extension on my Ubuntu server and am getting the below error. I've installed the ImageMagick rpm using aptitude already and the pecl extension is version 2.3.0. I've looked around online but can't find anything pointing me in the right direction. I also tried looking for anything that looked like it might be the Wand-config or MagickWand-config program that the error is mentioning but can't find any.

steven@server:/var/www$ sudo pecl install imagick
downloading imagick-2.3.0.tgz ...
Starting to download imagick-2.3.0.tgz (86,976 bytes)
.....................done: 86,976 bytes
12 source files, building
running: phpize
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20060613
Zend Extension Api No:   220060519
Please provide the prefix of Imagemagick installation [autodetect] :
building in /var/tmp/pear-build-root/imagick-2.3.0
running: /tmp/pear/temp/imagick/configure --with-imagick
*** ... snip ... ***
checking ImageMagick MagickWand API configuration program... configure: error: not found. Please provide a path to MagickWand-config or Wand-config program.
ERROR: `/tmp/pear/temp/imagick/configure --with-imagick' failed

I snipped most of the output because it didn't really seem to helpful but I can post if requested.

  • PHP is 5.2.4
  • ImageMagick is 6.3.7
  • Ran sudo aptitude upgrade today to upgrade RPMs as well before install ImageMagick
share|improve this question
up vote 22 down vote accepted

You need to install the ImageMagick devel package. In Ubuntu try:

sudo apt-get install libmagickwand-dev libmagickcore-dev
share|improve this answer
That did the trick, thanks – Steven Surowiec Aug 22 '09 at 1:21

It's in the ubuntu repos (version 2.0.1-1 for hardy), is there a reason you're trying to compile it yourself?

share|improve this answer
The version in the ubuntu repo for the version I was on (8.0.4) was 1.x and I needed at least 2.1.x. In the end I ended up upgraded to ubuntu 9 so I didn't have to. – Steven Surowiec Aug 22 '09 at 2:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.