Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to configure my CentOS 5.9 machine to dump a vmcore file to /var/crash when the kernel panics.

I have installed kernel-debuginfo and kexec-tools according to this site, with the exception that I installed kernel-debuginfo-uname -r to get the correct version associated with my current kernel.

When I do

#echo 1 > /proc/sys/kernel/sysrq
#echo c > /proc/sysrq-trigger 

The system will hang forever. Other things I've checked:

# cat /etc/kdump.conf
path /var/crash
core_collector makedumpfile -d 17 -c

# cat /proc/iomem |grep Crash
01000000-08ffffff : Crash kernel

# /sbin/chkconfig kdump on
# /sbin/service kdump restart
Stopping kdump:                                            [  OK  ]
Starting kdump:                                            [  OK  ]

# /sbin/service kdump status
Kdump is operational

I have also added crashkernel=128M@16M to the end of the kernel line in /boot/grub/grub.conf:

title CentOS (2.6.18-371.4.1.el5)
        root (hd0,0)
        kernel /vmlinuz-2.6.18-371.4.1.el5 ro root=/dev/md2 rhgb quiet crashkernel=128M@16M
        initrd /initrd-2.6.18-371.4.1.el5.img

I've spent a couple days now visiting various sites and trying their suggestions. I've also tried removing all the packages and reinstalling them. If anyone has any insight, it would be much appreciated.

share|improve this question
    
I just created a virtual machine and updated it to the same kernel version I'm using on the real machine. after installing kexec-tools and updating the grub.conf file, it worked fine on the virtual machine ( a dump file was created in /var/crash/ ). –  Corey Z Feb 7 at 18:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.